Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Bottom of 7” Screen quit working


Recommended Posts

MinnesotaAxis

A week ago, the bottom of the 7” screen on our 2016 25LSV quit working. Just the bottom 1/2 inch or so… across the entire bottom. The rest of it worked fine. Also, we can only play music through all the speakers (tower included) and if we try to adjust to just interior speakers, we get no music. Then last evening, the wedge decided to quit moving, along with the gates, and the back tanks won’t drain (the front two tanks will drain just fine).

 

It seems like a new screen might be needed, however before I drag it to the dealer, I  wanted to see if anyone here had an idea or has dealt with something similar. 
 

Thanks. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...