Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Raptor 410 alternator replacement?


Recommended Posts

Posted (edited)

It’s should be warranty but dealer says can’t get in till the 15th. They have one in stock. Ask if I could pull this one and bring it to them for warranty replacement and they refused. I may have to just buy it and install myself. 

Edited by dalt1
Link to post
6 hours ago, dalt1 said:

It’s should be warranty but dealer says can’t get in till the 15th. They have one in stock. Ask if I could pull this one and bring it to them for warranty replacement and they refused. I may have to just buy it and install myself. 

Will they give you the new one if you bring in the old one first?

Link to post
Posted (edited)

@Eagleboy99@formulaben@granddaddy55 No to everyone's question so far. I do not love my dealer, but only option.

Now has anyone taken one out yet? Looks easy enough if the belt tensioner is accessible. Have not had time to check yet. It is on top of the engine.image.thumb.png.766085e42cf35f55bade68751c8d1fbf.png

 

Edited by dalt1
Link to post

Access seems reasonable.  Cost aside, I'd definitely give it a try instead of waiting 2 weeks.  I'd lose my mind during that time...

Having said that, I'd verify it won't void your warranty if you have any left.

Link to post

@dalt1 - What are the symptoms?  You could pull it and take it to an alternator shop if you have one nearby.  Generally either the regulator dies or a diode in the rectifier blows.  Should be cheap to replace either one.

Link to post
Posted (edited)

No active or inactive codes showing before start.Hooked up water and started boat. Batteries were full charged as they have been plugged in to my Pro Marine charger since Monday. Alternator only showing 12.4 so it is not putting out. Now while running get a active code. Dealer says it is #8 coil has short or broken wire to coil. Will that keep alternator from putting out at least 13.5 - 14 volts? Will have to wait them out and take it in.image.thumb.png.1e4dd092b098e307b59f0800f0cdb663.png

Edited by dalt1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...