Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Couple of things to fix after first trip out after winter (need some guidance on ballast drain issue and speedo)


Recommended Posts

Good news is no cracked block after a good winterization last fall.  Was a little worried about the cold we had and if it was done right.  I did pay someone to do it.

I added the piggyback ballast to the rear lockers over winter and tried them out on the water today for the first time.  It is the wakemakers kit put on a 2011 VLX.  They filled great but on drain the left rear one would not drain at all.  I was wondering what happened and looked at the fuses and the one for drain rear left is blown. I was on the water and already had the others drained so I pulled 5 Amp fuse from another on the fuse block and inserted on the left rear slot.  Upon pressing the drain it again blew.  Any ideas and where is the drain pump.  Needless to say it was a fun drive back in and loading up.  Once out of the water I pulled the plug on the bag and let it drain out.  Guess I need to keep my old pump on board in case this happens again.  Hard tank is still filled. 

Other issue is bouncing speedo.  Really sucks when you are trying to use the built in cruise control.   It has the GPS upgrade so no clue what is going on there.  Screws you up when trying to pull someone when it thinks you are going 60 when really you are sitting still.  Thanks in advance.

Link to post

On the gps upgrade, where did you mount the antenna?  Your symptoms are consistent with low signal strength and/or multipath.

Link to post

The rear ballast drain pump is connected directly to the ballast tank with a plastic elbow and it is located at the very back of the tank under the floor.  There is a small screw holding a blue plastic retainer in place on the pump.  If you remove the screw and retainer the pump motor can be unscrewed by hand and pulled out of the pump body.

A small piece of debris caught in the impeller on the pump motor can cause the fuse to blow or the motor may be fautly.  Replacement pump cores with the wiring and weather pack connector are available from most Malibu dealers.

Link to post

The GPS module is screwed to the underside of the deck just forward of the helm.  If you turn the dash power off, then disconnect the four wire grey deutch connector from the module, then the speed input will switch to the hull paddle wheel when you turn the dash power button back on. 

Malibu has a toggle switch kit with a small mounting housing and wire harness available that will allow you to quickly switch between the GPS and paddle wheel.  The dash power must be turned off after using the toggle switch for the input change to take effect.

Link to post

Thanks for the reply guys.  I found the rear left drain pump and removed it and turned it by hand.  I them moved fuse to bypass and it worked.  Put it all back together and moved fuse back to normal and the problem is fixed.  I was able to drain the hard tank.  Problem is that when this happens on the water with 800 piggy back bag full you can’t get to the pump.  How are others addressing this?  I ordered two cartridges from wakemakers for future problems.

On the speedometer here are a few pics.  Are others having the same issue that require the toggle switch?

 

7809F951-92C9-4F7E-97ED-90D74665CDC1.jpeg

D5FFFDB3-5231-45AF-9FC9-4AF45403E273.jpeg

233C1C51-2340-4861-8A77-856ACAF2CEDB.jpeg

Link to post

That does not look like the the Medallion Malibu GPS speed module.  It looks like the NL4 kit from NauticLaugic.

http://nauticlaugic.com/nl4-xl_2021_Packages.html

It is a kit that connects inline to the paddle wheel wiring to send a speed signal to the gauge controller from the GPS receiver.  Contact them and see if they can help you diagnose and fix the problem.

If you follow the cable connected to the black rectangular box under the dash in your photo you will find the 4 pin metri-pack plug splice harness seen on the website link.  Disconnect the adaptor harness and plug the paddle wheel plug directly to the boat harness to use the paddle wheel for speed (if it is working).

Link to post

Thanks @csleaver.  I spoke with NL and I need to do some troubleshooting and they said I might need an update.  They also said the update of the software would be free.  If I need a new system it will be under $300.  Thanks for pointing me in the right direction.  I really hope I can get this fixed.  

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...