Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

exoticaxstin

Ballast draining problem

Recommended Posts

exoticaxstin

I have a 2008 23 lsv we just recently brought it from a previous owner who just replaced the ending and we went out today and when we filled the ballast it already showed the left tank was full before we started pumping. We didn’t think much about it till we went to drain and it said it never drained, at least  the screen showed it didn’t. all others did except the left rear tank. I’m wondering if it could be a bad fuze or pump or if something can be clogging it. we just got a new engine so i don’t know if something could’ve happened with that but yeah i would love some input thank you! also when we filled the right rear tank, it would leak in the locker. it stopped once it was full, but what could that be?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...