Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
spinxt

Reset trouble code in Malibu Gauge (2003 LXi)

Recommended Posts

spinxt

I had a couple fault codes on my 03’ LXi.  I have since fixed the issues and cleared the codes in the ECU with my laptop.  Stil When I power the ignition on,  I get a “”bad” readout on the Malibu LCD.   Every thing is fine now, but I can’t the lcd message to go away.... anyone have any idea how?

Share this post


Link to post
Share on other sites
Eagleboy99

Have you disconnected the battrery?

Share this post


Link to post
Share on other sites
spinxt
1 hour ago, Eagleboy99 said:

Have you disconnected the battrery?

I have a perko switch that I turn off when it’s sitting on the trailer between uses....doesn’t go away 

Share this post


Link to post
Share on other sites
Eagleboy99

And you are sure there is no current bleed from that switch?  Or something else energizing your system?

Share this post


Link to post
Share on other sites
spinxt
2 hours ago, Eagleboy99 said:

And you are sure there is no current bleed from that switch?  Or something else energizing your system?

It’s possible 

Share this post


Link to post
Share on other sites
csleaver

The BAD readout on the LCD display on the tachometer usually refers to the depth sounder.  They usually read BAD when first powered up, but then soon after will show your depth, unless the depth module is faulty or has a bad connection.  The LCD display is not connected to the engine ECM on a 2003 Malibu tachometer in any way that I am aware of.

Share this post


Link to post
Share on other sites
spinxt
5 hours ago, csleaver said:

The BAD readout on the LCD display on the tachometer usually refers to the depth sounder.  They usually read BAD when first powered up, but then soon after will show your depth, unless the depth module is faulty or has a bad connection.  The LCD display is not connected to the engine ECM on a 2003 Malibu tachometer in any way that I am aware of.

Ah...good to know... I do always have the depth screen up, so that makes sense.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...