Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Mglass09

Damper plate explosion - fiberglass repair

Recommended Posts

Mglass09
Posted (edited)

oNoz1A9Ri9he0Y3_S9OD-uY2TL2rh-ske8zk95yfSo long story short I had a catastrophic damper plate failure which led to some apparent fiberglass damage on the stringer near the port side motor mount.

Unfortunarely for me somehow I didn’t see this when I had the trans out so everything is back mounted and was just waiting for me to align.

Anyone with knowledge of fiberglass repair have any suggestions on how to fix this? It’s a vertical gouge and in some parts I can poke a screwdriver all the way through. I’m assuming it’ll have to be cut completely through to remove all the damaged glass. 

 

dOENZ_igKYEtljZsV0Zfv-cj2CAQK6-p82fRDgBE

Edited by Mglass09
Pics

Share this post


Link to post
Share on other sites
hawaiianstyln

wow I don't know about the fiberglass repair but not sure I would tackle that one and just take it to a local fiberglass shop.  I've just recently heard the rattling when in gear and I'm thinking it has to be the damper plate.  I'm going to get mine repaired as I have also read a few other articles on here from major failures.  I thought it was suppose to be 2005 models and the culprit is the bellhousing.  Make sure when you get that new damper plate (part # 885201) that you may just want to buy a new bellhousing for piece of mind.  Did you hear a rattle or knock while in gear before this all happened?

 

Share this post


Link to post
Share on other sites
MadMan

Do you have a picture of the blown out bell housing?

Good thing it a v-drive, if it were a direct drive that shrapnel could have hit someone in the boat.

Share this post


Link to post
Share on other sites
Mglass09

BvlGKOhcLmcqCrAn090wjOmqtxNGoL1YaAuR3XM9

Bell housing split completely in half, it was hanging on by a thread but as soon as I started lifting the motor up it split. Trans mounts were super loose and bell housing was missing a bolt and 1 was broken. I’ve only had the boat one season so it seems as though I inherited a mess.

 

Got her back together and on the water yesterday, runs great.

 

Only issue is i have constant warning beep and my engine temp sensor isn’t working. Ordered a new sensor but I think some wiring got damaged in the carnage 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...