Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Ryan1776

Ballast filling, on it's own

Recommended Posts

Ryan1776
Posted (edited)

So I made a mistake last year. 
When I upgraded my ballast last year, upgraded the pumps, and lines to 1 1/8". 

I put in the one way check valves. Then my Y to the tank and to the bag. 

My impression was that the check valve was to keep the bags and tanks from emptying thanks to Mr. Bernoulli. And that part works, but NOW because I didn't run that loop vertically, it fills on its own.... doh :Frustrated:

Do I really need those 37 dollar anti siphon loops now? Or can I just run a 1" 180° turn? 

 

Edited by Ryan1776

Share this post


Link to post
Share on other sites
Ryan1776

Alright everyone... Spent a lot of time digging and ended up finding these vented loops on ebay FOR SIGNIFICANTLY less than anyone. 

https://www.ebay.com/itm/293012789790?ul_noapp=true&autorefresh=true

I thought it was highway robbery to charge what Wakemakers and the like get for these formed piece of plastic with a vent. 13$ is more like it. 

Share this post


Link to post
Share on other sites
Ryan1776
1 minute ago, Eagleboy99 said:

And even more significantly less!  https://www.five-oceans.com/products/outlet-vented-loop-1-bc-2421  $6.99 is more like it.  :)  (Plus 15% off first order if you sign up!)

Yeah good catch!! But with shipping it's just about the same.....(without sign up) (I offered 11 bucks each)  
I posted this in deal street, I'll update with that! Well done sir. 

Share this post


Link to post
Share on other sites
mswsetter00

You just need a high point in your hose, above water line. I have aerator pumps and check valves, no vent loop. No auto fill. I was getting Auto Draining. :Frustrated: But fixed it with the check valve.

 

Share this post


Link to post
Share on other sites
Ryan1776
15 hours ago, mswsetter00 said:

You just need a high point in your hose, above water line. I have aerator pumps and check valves, no vent loop. No auto fill. I was getting Auto Draining. :Frustrated: But fixed it with the check valve.

 

Ya know. I thought I had enough of that "high point" but obviously not. I had the check valve. I removed the check valve and installed those loops back in the original location. It's still sh*t weather here so no idea if it works. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...