Jump to content
crit111

06 Response Lxi speedometer showing speed when not moving

Recommended Posts

crit111

I'm struggling with the speedometer on my 06 Response Lxi.  When I first bought the boat, it would only work occasionally...when it did, it was very flaky/incorrect (all over the map, 20 mph to 50mph while traveling at a constant speed).  Checked paddle wheel, spins without issue, no missing paddles.  Checked wires, connectors under dash, unplug, replug, etc.  Still did the same thing.  

Over the 4th of July, the speedometer worked correctly for about an hour (the first time its ever done that).  May or may not be relevant, but the depth finder was also working during this hour; also the first time it's ever worked and showed anything other than .5 feet.  Turned boat off, ate lunch, went back out and speedometer had lost its mind again.  Now, while just idling and not moving, the speedometer is jumping all over the place.  Does the same thing while moving.  Depth finder stopped working as well.  

I've combed the threads on this forum but can't seem to find anything tangible to try as a next step.  Any help would be appreciated!

 

   

Share this post


Link to post
Share on other sites
crit111

OK, I get it, I'm a total n00b/Ballast Buddy on this forum...with that said, I'm stubborn and need to get to the bottom of this (with someones help/advice preferred!).  

Per various threads, I've followed the following  advice:

- Unplug & reseat connectors under dash, behind the gauges, in engine compartment.  Squirted with electrical contact cleaner for good measure.  

- Unscrew every screw on terminal block under dash, check every termination/crimp/fork/ring terminal/spade connector attached to said terminal block and then re-attach.  

- Removed ground from alternator, sanded, re-attached.  Did the same for another ground near the back of the engine.  

- Unplug & reseat connectors in engine compartment.  

- Removed batteries, cleaned terminals (and leads).  Swapped battery 1 & 2 between positions on the on/off/both switch, no difference.

- Swapped connector behind dash from speedo/depth/air & outside water temp gauge with one of the other gauges that works 100% of the time, no change.  

- Followed the Medallion II troubleshooting guide, no smoking guns. 

One note that is worth mentioning, when the speedo is jumping all over the place and you pull power back to idle, it idles fast, about double what it should (1100/1200 RPM).  Like clock work, wait anywhere from 5 to 30 seconds, the speedo will stop dancing, return to zero...once this happens, the idle returns to normal.  Sometimes grabbing/wiggling wires under the dash will make the return to normal happen faster, other times it does absolutely nothing and I just have to wait.  

I found this thread today: http://www.themalibucrew.com/index.php?/forums/topic/50826-mdc-repair/.  Seemed to have enough common ground with my issue so I took mine apart.  Based on the pic here: https://photos.app.goo.gl/F4wzt2yzXXzFMPBP6, (hopefully that link will work...) it doesn't look horrible but is there enough corrosion/junk to cause a short?

I appreciate the help.  

 


 

Share this post


Link to post
Share on other sites
Intheday

Sounds like an earth problem.  I know that’s not much help 

Share this post


Link to post
Share on other sites
drh

@crit111 This sounds like either a grounding issue or the paddle wheel sensor is bad. From what I've read those paddle wheel sensors also take the lake temp - with that being said if your lake temp reading looks accurate that could eliminate the possibility of a grounding issue. Also, a bad ground might also show up in other instruments. This was the case for me - when I turned on an accessory like the blower or radio my gauges would increase in value slightly with each additional accessory switched on. When I turned off the accessory they would go back down. I ran a thick gauge wire from the negative terminal on the battery to the grounding bar under the dash where all the black wires attach to fix the issue.

You could also test the paddle wheel with a multi meter - you should get 12 volts and 0 volts alternating between the green wire and ground wire as you turn the wheel. See diagram here: https://www.bakesonline.com/paddle-wheel-speedometer-with-lake-temperature-sensor.html.

 

Share this post


Link to post
Share on other sites
JasonK

On mine, I found the paddle wheel wire under the dash was "nicked" like it was rubbed until it got cut.

Share this post


Link to post
Share on other sites
crit111

I appreciate the insight!  The plug connections soldered to the MMDC board didn't look corroded but I cleaned the residual flux off the back for good measure.  

@drh, the lake temps shown on the gauge look reasonable, they'll change from day to day and/or between different lakes.  I'll hunt down the blower and check for anything back there.  I'm definitely going to try running a cable direct from the negative battery terminal to the terminal block under the dash, just as a temp setup to see what happens; thanks for the idea.  

Looks like chasing wires (again) with a multimeter is next on the list.  

Thanks again and I'll report back when I find the electrical gremlin.  

Share this post


Link to post
Share on other sites
crit111

JACKPOT!  Two of the three electrical gremlins have been evicted.  As I stated above, I had unplugged and replugged every connector I could find in the engine compartment and under the dash... what I had failed to do is inspect "with great detail" the wires feeding each connector.  Low and behold, back in the engine compartment on a large 16 pin (Delphi ?) connector, the retaining clip which holds the mated connectors to a metal plate had fatigued, wires rubbed on side of metal plate, copper was visible through wire insulation on least four wires.  #NotOptimal  
IMG_5203.jpg

For each of the damaged wires, I pulled them out of the connector, wrapped a small piece of electrical tape around the area, installed a piece of heat shrink tubing over the tape (probably overkill) and re-inserted the wire into the connector.  I did a little work on the retaining clip and harness routing to prevent the issue from happening again. 

Now my speedo is rock solid, no bouncing and no errant readings while in neutral.  The idle speed issue when the gauge was spazzing out is also resolved.

The only item left on the list is the depth finder.  It still shows 0.5 feet the majority of the time.  When the key is initially turned on and/or when boat is started it reads 5.6 ft, drops to 1.3, then settles at 0.5 ft.  There was a single instance yesterday while on the water where it worked for about 10 seconds immediately after I started the boat…it was showing ~15 feet.  To no avail, it stopped working and went back to .5 ft.  I found the MalibuComputronGuide on bakesonline but apparently the modules it describes were only available on boats prior to 1999?  Parts of the document line up to what I’m finding under the dash, others aren’t, but hopefully it’ll provide enough context to point me in the right direction.     

Share this post


Link to post
Share on other sites
JasonK

I'll check those on mine and see what they look like.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×