Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Bloat

2007 LCD screen dark and blank

Recommended Posts

Bloat

I have a 247 LSV wakesetter with a blank lcd screen, so i was unable to use the cruise system on the weekend. I cycled the engine and turned off the batteries a few times but it did not solve the problem. Checked every relay, but they were fine. Boat runs good and every other guage works fine. Is there a fuse under the dash specifically for the lcd display? Its been very rainy/stormy over the last couple weeks so wondering if it may just be moisture getting into the display causing issues. Wont have time to evaluate it again until next weekend, so was just wondering if anyone else has had this problem or has any suggestions to try next time im out. 

Thanks for any input.

Share this post


Link to post
Share on other sites
Ndawg12

Have you pulled the gauge assembly out and verified the unit is still plugged in?

Share this post


Link to post
Share on other sites
Bloat

No, but will verify its still plugged in when i get out again...perhaps some rough water dislodged something an electrical connection. Would be nice for an easy fix. Thinking it could be ssomething simple like that, as not alot of people have had issues with the older lcd screens. 

Share this post


Link to post
Share on other sites
Bloat

Just an update for future troubleshooters...

LCD functions fine now.

it was a little glitchy when I checked it out again. (buttons not working and screen intermittent....but at least working sometimes)....checked the electrical connections and used a fan to air out the area.

After a couple days of use seems to all function 100%. Got a lucky this round. Think it was a moisture issue.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×