Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

webco

Transimission won't completely disengage in neutral

Recommended Posts

webco

Anybody know what is causing my '07 V-Ride from creeping forward when idling in neutral? Is there an adjustment to correct this? Any ideas appreciated! Thanks.

Share this post


Link to post
Share on other sites
oldjeep

Creeping forward like the underwater exhaust is pushing you? 

Share this post


Link to post
Share on other sites
kbsuperjet

I have a Calabria direct drive that is doing the exact same thing.

Share this post


Link to post
Share on other sites
boardjnky4

Sadly, I think you’re going to find that your transmission is toast.

I had to replace mine for the same problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...