Jump to content
Sign in to follow this  
malibucanuck

93 Echelon wiring diagram

Recommended Posts

malibucanuck

Hey everyone, I'm a new Malibu owner(not the boat) and am looking to find a wiring diagram

for my 93 Eschelon. I need it to include if,possible,the scematics for the Computron.

I know this system is antiquated but I'm holding out hope that I have a loose connection at a sensor

since it works fine from time to time. Any advice would be appreciated.

Doug

Share this post


Link to post
Share on other sites
ibelieve

I seem to remember that the are some chips in sockets on the circuit cards in the Computron unit. I would pull and re-seat the chips as well as clean the contacts on the cards and re-seat them.

There use to be a company in Little Rock, AR that would do repair work on them. They were the manufacture. Not sure if they will still work on them or not and I can't remember the name of the firm. The name may be in a post here or on malibuboatowners.com. I seem to remember posting it at one time but it may have been purged.

Here is some more info on the computron ... just found on that other site.

The compmay that built the computron is :

Uniforce Technologies Inc

(501) 945-3283

1805 E 5th St

N Little Rock, AR 72114

Maybe they still have some parts kicking around?

I have the price list for parts from back then. You would order from them. This list was good until Jan 1 1995

Imagine what those prices would be now if they were still available.

Main Computer Module - 89.00

Display Module - 89.00

Depth R/T Module - 29.00

Depth Transducer - 25.00

Push Button IR Steering wheel Assemble - 29.00

Steering Wheel Hub Assembly Reciever - 29.00

Temperature Probe - 29.00

For 2nd day UPS Air add - 4.00

For next day UPS add - 14.00

The users manual can be found here http://www.wakesiderides.com/forums/index....showtopic=16669

/Steve

Edited by ibelieve

Share this post


Link to post
Share on other sites
JDubya
I seem to remember that the are some chips in sockets on the circuit cards in the Computron unit. I would pull and re-seat the chips as well as clean the contacts on the cards and re-seat them.

There use to be a company in Little Rock, AR that would do repair work on them. They were the manufacture. Not sure if they will still work on them or not and I can't remember the name of the firm. The name may be in a post here or on malibuboatowners.com. I seem to remember posting it at one time but it may have been purged.

Here is some more info on the computron ... just found on that other site.

The compmay that built the computron is :

Uniforce Technologies Inc

(501) 945-3283

1805 E 5th St

N Little Rock, AR 72114

Maybe they still have some parts kicking around?

I have the price list for parts from back then. You would order from them. This list was good until Jan 1 1995

Imagine what those prices would be now if they were still available.

Main Computer Module - 89.00

Display Module - 89.00

Depth R/T Module - 29.00

Depth Transducer - 25.00

Push Button IR Steering wheel Assemble - 29.00

Steering Wheel Hub Assembly Reciever - 29.00

Temperature Probe - 29.00

For 2nd day UPS Air add - 4.00

For next day UPS add - 14.00

The users manual can be found here http://www.wakesiderides.com/forums/index....showtopic=16669

/Steve

I have contacted the company with little help. They basically no longer provide ANY support for the computron. It is a relic as far as they are concerned. What sort of problems are you having. Let us know if you get anything out of Uniforce.

Jonny

Share this post


Link to post
Share on other sites
malibucanuck

I seem to remember that the are some chips in sockets on the circuit cards in the Computron unit. I would pull and re-seat the chips as well as clean the contacts on the cards and re-seat them.

There use to be a company in Little Rock, AR that would do repair work on them. They were the manufacture. Not sure if they will still work on them or not and I can't remember the name of the firm. The name may be in a post here or on malibuboatowners.com. I seem to remember posting it at one time but it may have been purged.

Here is some more info on the computron ... just found on that other site.

The compmay that built the computron is :

Uniforce Technologies Inc

(501) 945-3283

1805 E 5th St

N Little Rock, AR 72114

Maybe they still have some parts kicking around?

I have the price list for parts from back then. You would order from them. This list was good until Jan 1 1995

Imagine what those prices would be now if they were still available.

Main Computer Module - 89.00

Display Module - 89.00

Depth R/T Module - 29.00

Depth Transducer - 25.00

Push Button IR Steering wheel Assemble - 29.00

Steering Wheel Hub Assembly Reciever - 29.00

Temperature Probe - 29.00

For 2nd day UPS Air add - 4.00

For next day UPS add - 14.00

The users manual can be found here http://www.wakesiderides.com/forums/index....showtopic=16669

/Steve

I have contacted the company with little help. They basically no longer provide ANY support for the computron. It is a relic as far as they are concerned. What sort of problems are you having. Let us know if you get anything out of Uniforce.

Jonny

Share this post


Link to post
Share on other sites
malibucanuck

I seem to remember that the are some chips in sockets on the circuit cards in the Computron unit. I would pull and re-seat the chips as well as clean the contacts on the cards and re-seat them.

There use to be a company in Little Rock, AR that would do repair work on them. They were the manufacture. Not sure if they will still work on them or not and I can't remember the name of the firm. The name may be in a post here or on malibuboatowners.com. I seem to remember posting it at one time but it may have been purged.

Here is some more info on the computron ... just found on that other site.

The compmay that built the computron is :

Uniforce Technologies Inc

(501) 945-3283

1805 E 5th St

N Little Rock, AR 72114

Maybe they still have some parts kicking around?

I have the price list for parts from back then. You would order from them. This list was good until Jan 1 1995

Imagine what those prices would be now if they were still available.

Main Computer Module - 89.00

Display Module - 89.00

Depth R/T Module - 29.00

Depth Transducer - 25.00

Push Button IR Steering wheel Assemble - 29.00

Steering Wheel Hub Assembly Reciever - 29.00

Temperature Probe - 29.00

For 2nd day UPS Air add - 4.00

For next day UPS add - 14.00

The users manual can be found here http://www.wakesiderides.com/forums/index....showtopic=16669

/Steve

I have contacted the company with little help. They basically no longer provide ANY support for the computron. It is a relic as far as they are concerned. What sort of problems are you having. Let us know if you get anything out of Uniforce.

Jonny

Thanks guys for the info.

I'll explain briefly what happens...

When the key is turned to the on position lites will begin to flash on the top screen.,no letters or numbers

just flashing lites.

in the center screen usually 4 lines(----) then a 0 or a 00.00.

Bottom screen will often have letters which make no sense.

This will usually go on for several start/stops. I'll never know if it is working until the engine is running.

Them all of a sudden the next time I start up the scenter screen will read ---- ,I'll move through the modes wih either the dash buttons or steering wheel and everything appears to be working, speed ,stop watch, clock, speedo, rpm, hour meter etc.(some stuff I don't know,I haven't had time to read the manual yet).

Nothing ever appears in the bottom screen.

If you have any Ideas ?

Thanks

Doug

Share this post


Link to post
Share on other sites
JDubya

Sounds like the PC card might be loose, or have bad contacts.

First disconnect the battery. If you look under your dash you see a black box stright in front of you. Pull the four pins on the small cover and you will see a chip card with yellow tabs on the side. Pull this card stright out towards you (Not the oreientation for when you replace the card).

Clean the contacts real well with electronic cleaner (can be bought at radio shack). You can also use a eraser for this. Once you have cleaned the contacts on either side replace the card and the cover. Connect the battery and fire it up.

if this does not fix the problem, then it is likely that you have a bad circuit.

Jonny

Share this post


Link to post
Share on other sites
malibucanuck
Sounds like the PC card might be loose, or have bad contacts.

First disconnect the battery. If you look under your dash you see a black box stright in front of you. Pull the four pins on the small cover and you will see a chip card with yellow tabs on the side. Pull this card stright out towards you (Not the oreientation for when you replace the card).

Clean the contacts real well with electronic cleaner (can be bought at radio shack). You can also use a eraser for this. Once you have cleaned the contacts on either side replace the card and the cover. Connect the battery and fire it up.

if this does not fix the problem, then it is likely that you have a bad circuit.

Jonny

Thanks I'll give it a try

Doug

Share this post


Link to post
Share on other sites
MIKEGOUGH1

I had a similar problem with my Computron, took it apart and cleaned it real good with contact cleaner and it took care of the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×