Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
DRAGON88

Auto-fill ballasts?

Recommended Posts

DRAGON88

Does anyone else experience their tanks filling after draining them? I have, I don't think much gets back in, but it's enough to make the ballast pumps run for another 5 seconds or so... I searched, but had no luck. Am I alone? Is this to be expected?

It's kind of sad/ironic, this was the last thing that I got around to fixing on my SAN before it was murdered. :(

-Richard

PS: I learned what happens when you leave the center plug out, even after writing a note and sticking them to the keys I STILL managed to forget, until I realized "hey the bilge pump light is on, why is it on?" I then proceeded to open the center access door and it sprayed water all over the inside of my boat. At that point I remembered what I did wrong and put the plug back in... DOH. Innocent.gif

Share this post


Link to post
Share on other sites
srud
Does anyone else experience their tanks filling after draining them? I have, I don't think much gets back in, but it's enough to make the ballast pumps run for another 5 seconds or so... I searched, but had no luck. Am I alone? Is this to be expected?

It's kind of sad/ironic, this was the last thing that I got around to fixing on my SAN before it was murdered. :(

-Richard

PS: I learned what happens when you leave the center plug out, even after writing a note and sticking them to the keys I STILL managed to forget, until I realized "hey the bilge pump light is on, why is it on?" I then proceeded to open the center access door and it sprayed water all over the inside of my boat. At that point I remembered what I did wrong and put the plug back in... DOH. Innocent.gif

I only have this issue with my center ballast. Mine will fill completely. Interestingly enough, it only does this after I have filled it and drained it once. If I haven't filled it, it doesn't self fill and will stay empty all day.

Share this post


Link to post
Share on other sites
jphillips

Drill a small hole in the handle of the plug and when you remove it attach it to your key chain. Put the plug on the drivers seat, this is a not as good as it can be moved.

Share this post


Link to post
Share on other sites
CincyKid

Yah, we have the same problem. We've got a 2005 Wakesetter VLX.

Share this post


Link to post
Share on other sites
desifire911

i have the same problem on my 05 vride the center ballast tank fills on its own. my dealer put a one way check valve in but there is'nt enough pressure to open the valve. very frustrating!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...