Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
williemon

Engine keeps having a stumble

Recommended Posts

williemon

I can be running 2500  to 4000 rpm and the issue is the same. Every now and again, the engine will be running fine and it will just seum le just for a second. Enough to make you think its about to fail and then its back to smooth running again. Ive been dealing with fuel issues this year. Cleaned injectors, fuel rail, replaced lines, filters, drained and inspected tank, pickup, replaced fuel pump and filter and fuel regulater. Engine runs real good and strong except for the stumble every so often. If it were a carb. Id swear it was water in the fuel. Do injected engines act that same way? How noticeable is it when one cylinder cuts out for a second when not under any load except for cruising? Ive also replaced spark plugs, cap rotor and wires this year. 2001 vlx with monsoon. 

Share this post


Link to post
rabiddawg

Safety kill switch was causing mine to do the same thing. 

Share this post


Link to post
wdr

I had kind of the same issue except everything went dead then rebooted back to normal. Turns out it was a bad crimp on the ignition reset switch wires on the driver side panel under the throttle.

image.jpeg

Share this post


Link to post
williemon

I pulled the kill switch and cleaned with contact cleaner. I called myself checking the wires on the breaker panel. No luck. Still gets that stumbel every once in awhile.

Share this post


Link to post
williemon

I will pull the inline fuel pump out (looks like it is a 40 micron) and install a water seperating filter (10 micron) and see what happens. I may even stick a magnet to it as well to catch the metal dust thats moving around in my fuel.

Share this post


Link to post
williemon

I have once again removed the fuel pump, injector fuel rails, injectors, fuel lines. Cleaned them all. Not any real junk to speak of was noticed. There was a little fine particles in each injector basket so i cleaned those out a bit with carb cleaner spray. Put it all back together, added the water seperator fuel filter, and fired it on the hose. It ran good on the hose. Now its time for a lake test. 

Share this post


Link to post
formulaben

When is the last time you replaced the plugs, rotor, cap and spark plug wires?

Share this post


Link to post
williemon

This  past spring for all.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...