Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
wakeNsurf

Anybody replace wedge actuators?

Recommended Posts

wakeNsurf

Well not a great week on the water, I hit a submerged stump with my wedge down and ripped the actuators off it along with bending it slightly. I believe I can straighten the wedge (only bent about 1/2 inch) but the actuators have to be replaced entirely (already spoke to Lenco, they don't just sell the plastic tops that ripped). I ordered from Bakes since they were about 40% less than my local dealer, my question is has anybody done this and if so how difficult? From my experience with my dealer it would take them over a month to get this done, I want to get back on the water working ASAP (I zip tied up the wedge so we could still use the boat after it happened)

FYI is a 2014 MXZ if that makes any difference

Share this post


Link to post
Chris2e

I just did it a month ago and with the help from a couple posts on here, it was pretty easy - probably 1.5 hours for the whole process (half hour figuring it out, 45 minutes for the first one and 15 for the second after I knew what I was doing)

Share this post


Link to post
OxDoc

I hope you have better luck than I did bending the wedge. I had a shop bend it back and by looking at it you could never tell that it had been bent. However, every time I used it on the water the wake would wash on one side. I ended up buying a new wedge and all is good.

Share this post


Link to post
khelfrich

they are easy to replace just loosen the cord grips and pull the old wires out shove the new ones in i added a little silicon to the wires as i slid them in. then just splice them in behind the engine where the factory sad spliced them in

as far as the whole 3 lobe 5 lobe thing i just put in the newer ones i think 5 lobe where i did have 3 lobe and had no problems. i think the whole thing about not being interchangeable is BS my gauge works and so does the auto wedge

Ken

Share this post


Link to post
TallRedRider

they are easy to replace just loosen the cord grips and pull the old wires out shove the new ones in i added a little silicon to the wires as i slid them in. then just splice them in behind the engine where the factory sad spliced them in

as far as the whole 3 lobe 5 lobe thing i just put in the newer ones i think 5 lobe where i did have 3 lobe and had no problems. i think the whole thing about not being interchangeable is BS my gauge works and so does the auto wedge

Ken

Your boat is the 2008 listed in your profile?

I thought the problem was when you put the older 3 lobe on a system designed for 5. I am sure someone will know but I was thinking roughly 2011- ish was when the stock actuators were 5 lobed. Putting new 5 lobed on a 3 lobe is probably not an issue.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...