Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
BlitzedVLX

Center Ballast pump non responsive

Recommended Posts

BlitzedVLX

Hey guys, I am have a problem with my center ballast. I press the button on the mux gauge to fill the center ballast and the boat does not click on like the others and start to pump nor do I hear a sound to dump. Further investigation of this problem led to the discovery of the no. 5 fuse blown associated with the pump. I replaced the fuse with rear ballast drain and it blew the replacement when I attempted to fill the center. I believe there may be a short somewhere in the wiring to the center fill. I also do not hear any noise when I press drain on the center. The center tank worked just fine at the end of last summer. Any ideas of where to start greatly appreciated.

Share this post


Link to post
shawndoggy

start by replacing the fuse again, taking the pump cartridge out, spinning the aerator by hand, then put power to it. sometimes the pirahna pumps get bound up over the winter. I think ruffdog says he always hits them with a heavy screwdriver or his purse or something before the start of the season to get them freed up.

Share this post


Link to post
BlitzedVLX

start by replacing the fuse again, taking the pump cartridge out, spinning the aerator by hand, then put power to it. sometimes the pirahna pumps get bound up over the winter. I think ruffdog says he always hits them with a heavy screwdriver or his purse or something before the start of the season to get them freed up.

Problem solved as per Shawn's recommendation. Took the pump apart and spun the aerator by hand and replaced the fuses with the boat off. Pump now fills and drains as should.

Share this post


Link to post
BigE

Ah, I hate to ask, but...

Could someone walk me thru taking the pump out, and cleaning it?

My center pump is running but the tank isn't filling. I'm hoping to clear an obstruction?

Thanks!

Share this post


Link to post
wdr

BigE, shouldn't have to take the pump out to check it. Unscrew the set screw/wedge piece on the top of the pump and then unscrew the blue ring. Pull the cartridge assembly out and clean and inspect as necessary. I have pictures of the screw and the unassembled pump housing in my mods section in the boat house if you want to see the parts. If you want or have to replace it you will have to cut or otherwise disconnect the wires (at an easily accessable point) disconnect the hose and unscrew the whole assembly from the ball valve.

Share this post


Link to post
malibu.c.c

got the same problem worked fine now first time in not working ,keeps blowing fuse ..

where is the center drain pump ???

so i can try your tricks ..

thks

Share this post


Link to post
Bill_AirJunky

Midship & bow tank pumps are in the center hatch to the left of the driver's seat.

Very easy to do this while it's still installed.

I just replaced the midship drain pump on mine over the winter. The impeller was frozen & blew the circuit protector all too often. When I opened it up & spun it by hand it felt like it had gravel in the bearings. I found replacements for the Piranha 800 on Ebay for around $50 shipped.

Edited by Bill_AirJunky

Share this post


Link to post
malibu.c.c

thks!!!

Share this post


Link to post
bamabonners

start by replacing the fuse again, taking the pump cartridge out, spinning the aerator by hand, then put power to it. sometimes the pirahna pumps get bound up over the winter. I think ruffdog says he always hits them with a heavy screwdriver or his purse or something before the start of the season to get them freed up.

:lol: I caught that...

Share this post


Link to post
DoubleM

Gang, first timer here...  I have same issue with center ballast fill not working.  Center drain works fine.  The actual pump works fine because I connected it to another power source (front fill power) and ran the motor out of the pump housing.  So my guess is I have a fuse problem.  That said, where is the fuse for the center ballast fill?? Doesn't appear on the panel below the throttle...  Thanks much.  Matt.

Share this post


Link to post
h2ojunkie

Under your drive side dash, big black box cover, fuses are under there.  If keeps kicking fuse pump cartridge could be frozen or some debris.  I clean mine out and use 303 to lube cartridge motor and the housing.  Test it before ya put cartridge back in and don't over tighten the lock ring. To tight can cause it to stick and blow fuses. Hope it helps ya.

Share this post


Link to post
DoubleM

Thanks much H20!  I will check it out this weekend. 

Share this post


Link to post
exlonghorn
On August 7, 2016 at 3:51 PM, DoubleM said:

Gang, first timer here...  I have same issue with center ballast fill not working.  Center drain works fine.  The actual pump works fine because I connected it to another power source (front fill power) and ran the motor out of the pump housing.  So my guess is I have a fuse problem.  That said, where is the fuse for the center ballast fill?? Doesn't appear on the panel below the throttle...  Thanks much.  Matt.

Do you have a Multimeter?  I honestly can't imagine owning a modern wake boat without one.  Test to see if you're getting low voltage, or no voltage, at the connector to the wires for the pump.  I've seen these pumps not operate if the voltage is less then 11.3V.  A little corrosion, a nicked wire, or a bad connection can cause the pump to stop working.  

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...