Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
rcombs78

Factory Ballast Switch On 07 Vride

Recommended Posts

rcombs78

I put the boat in for the first time this year and noticed my center hard tank switch wasn't lit up. I checked and it wasn't filling. I then checked the fuse and it was sticking out so I pushed it in to reset. It popped again. It has 545 hours on it. Is there something common that goes bad over time? Is this a pretty simple fix? Any help is greatly appreciated!!

Thanks,

Ryan

Share this post


Link to post
shawndoggy

open up the fill pump and spin the aerator with your finger, then put it back together and see if it works.

Share this post


Link to post
Bill_AirJunky

The same thing happened to the drain pump in my center ballast tank.... same symptoms. I yanked the pump when I put the boat away for the winter & have it sitting on the bench. I just walked downstairs & opened it up. The impeller was frozen. I turned it back & forth a few times with more pressure & it broke loose. Spun like it had gravel in the bearings. The more I spin it the better it seems to feel.

I see the Piranha 800 gph pumps on Ebay for $50 shipped. Sounds like the first task I'll be doing this spring. :rockon:

Edited by Bill_AirJunky

Share this post


Link to post
rcombs78

Thank you both so much! I"ll give this a shot and let you know!!!

The same thing happened to the drain pump in my center ballast tank.... same symptoms. I yanked the pump when I put the boat away for the winter & have it sitting on the bench. I just walked downstairs & opened it up. The impeller was frozen. I turned it back & forth a few times with more pressure & it broke loose. Spun like it had gravel in the bearings. The more I spin it the better it seems to feel.

I see the Piranha 800 gph pumps on Ebay for $50 shipped. Sounds like the first task I'll be doing this spring. :rockon:

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...