Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
ralph 39

problems with 320 vortec

Recommended Posts

ralph 39

Have just brought brand new 05 response lx with the new 320 fuel injected vortec engine.the problem is you can ski for hours on end but soon as you let it sit for more then 30 minutes it wont idle, when you turn it over it starts then dies.

dealer has changed the fuel filter, fuel pump,plugs.

has any one had any problems

Share this post


Link to post
Share on other sites
Baddog

Not sure if this is it but mine was doing other weird things and it turned out to be the water temperature sensor, a $30 part.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...