Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
ryan04wakesetter

Perfect Pass Tach analog gauge gone bad

Recommended Posts

ryan04wakesetter

Hello everyone,

I have a 2004 Malibu Wakesetter DD and the tach on the perfect pass gauge has gone bad. The digital read out is still coming through for the rpm so it is working, but the actual needle is not functioning. I was told by my dealer who contacted perfect pass that they still have some of the 03 gauges with the black face which will not match. Does anyone know where I could get the original 04 perfect pass gauge? Thanks in advance. Here is an image of the gauge: http://www.pcs.cnu.edu/~cpinto/boat/boat8.JPG

Share this post


Link to post
tvano

Hello everyone,

I have a 2004 Malibu Wakesetter DD and the tach on the perfect pass gauge has gone bad. The digital read out is still coming through for the rpm so it is working, but the actual needle is not functioning. I was told by my dealer who contacted perfect pass that they still have some of the 03 gauges with the black face which will not match. Does anyone know where I could get the original 04 perfect pass gauge? Thanks in advance. Here is an image of the gauge: http://www.pcs.cnu.e.../boat/boat8.JPG

it can probably be repaired.

take a look at this thread

that era combined mechanical tach and pp display would corrode at the brass "T" bolt where it connects to the circuit board.

a couple of hours of tinkering to fix it.

Share this post


Link to post
ryan04wakesetter

it can probably be repaired.

take a look at this thread

that era combined mechanical tach and pp display would corrode at the brass "T" bolt where it connects to the circuit board.

a couple of hours of tinkering to fix it.

I checked the posts where it connects and they look clean and in tact. The malibu tech is telling me the gauge is connected properly and getting everything it needs to function so it must be a problem within the gauge itself.

Share this post


Link to post
ibelieve

The problem is on the inside and you must disassemble the gauge to fix it. Like the previous post said, a couple hours of work. Read the full post he referenced.

/Steve

I checked the posts where it connects and they look clean and in tact. The malibu tech is telling me the gauge is connected properly and getting everything it needs to function so it must be a problem within the gauge itself.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...