Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
buckeyeryan

Blower Motor replacement???

Recommended Posts

buckeyeryan

I own a 2002 response and noticed the last time out that when the blower motor is turned on, it makes a funny noise (like a grinding) and the air is only blowing out of one side of the rear of the boat. Anyone else have this problem?? I am assuming the motor is about to blow. Wanted to get with the "pros" before moving forward with this.

Share this post


Link to post
Bill_AirJunky

Probably a good idea to look at the motor first. My Vride only blows out one side anyway, the other side is a fresh air inlet. But I'd make sure all your hoses are hooked up correctly so that even if the motor is on it's last legs, it's still blowing out & not just blowing inside the engine compartment.

Blowup.gif

I picked up a replacement motor off Ebay for like $15 or $20. Most any boat/marine shop will have 2 or 3 different brands to chose from for a little more expensive. I just went with the same inlet/outlet size & the same air flow rate. I think the old one was rated in CFMs.

Edited by Bill_AirJunky

Share this post


Link to post
Baddog

Is it kind of a squeal? Mine does that sometimes and then not at all. I suspect a bit of corrosion starting. Could try cleaning it.

Share this post


Link to post
Ndawg12

Is it kind of a squeal? Mine does that sometimes and then not at all. I suspect a bit of corrosion starting. Could try cleaning it.

BD, how long has yours been doing it? Mine started squealing about half way through last year. I'm not real concerned since it gets a nice 15 minute ride to the ramp without the cover and just a couple times out on the water.

Edited by Ndawg12

Share this post


Link to post
Jimmypooh

Is it kind of a squeal? Mine does that sometimes and then not at all. I suspect a bit of corrosion starting. Could try cleaning it.

BD, how long has yours been doing it? Mine started squealing about half way through last year. I'm not real concerned since it gets a nice 15 minute ride to the ramp without the cover and just a couple times out on the water.

The squealing usually comes from the electric motor. It's where the brushes come in contact with the commutator:

armature_commutator.gif

A possible fix that I've used is taking some steel wool and rubbing it on the commutator, or lightly scratching it with the end of a screw driver. This will allow the commutator and brushes to reset. The "correct" fix would be to grind your commutator with a comm stone and replace your brushes.

Hope this helps if the squealing gets too annoying

Share this post


Link to post
Ndawg12

The squealing usually comes from the electric motor. It's where the brushes come in contact with the commutator:

armature_commutator.gif

A possible fix that I've used is taking some steel wool and rubbing it on the commutator, or lightly scratching it with the end of a screw driver. This will allow the commutator and brushes to reset. The "correct" fix would be to grind your commutator with a comm stone and replace your brushes.

Hope this helps if the squealing gets too annoying

Is it easy to get the motor out of the housing?

Share this post


Link to post
Marine Specialty

Just buy a new one! If the blower is not working properly and gas fumes build up there could be big Blowup.gif. It is not something to over look in the bu. I have seen first hand what happens to a boat that has fumes built up and you start the boat, it is all over there is no putting out the fire. IMO.

Share this post


Link to post
Bill_AirJunky

Yea, I second it. Don't mess around. Consequences are way too huge. I run mine way more than I "should". Better safe than sorry.

I know for a fact when mine got wet. It didn't Last for than 3 or 4 weeks before it started squeeling.

Share this post


Link to post
buckeyeryan

Thanks for all the help guys and/or girls. I will check on the motor and probably end up getting a new one.

Share this post


Link to post
Baddog

BD, how long has yours been doing it? Mine started squealing about half way through last year. I'm not real concerned since it gets a nice 15 minute ride to the ramp without the cover and just a couple times out on the water.

Last two years. I ought to replace it . . . . ..

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...