Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
bigeasybu

overheating

Recommended Posts

bigeasybu

1998 echelon 350cid being in new orleans my boat is never winterized about 1 a month i start it on the fake a lake then let it run 15-30 minuites at around 900 rpm.the temperture never goes above maybe 140 degrees f.so today first launch start engine and as im idiling away from the launch i notice that the temp is rapidly climing.in less than 3 min it was up to 220. put it back on the trailer went home.the sea filter is clear,transmission cooler clean,then i come to the thermostat and housing.HOW DOES THE THERMOSTAT COME OUT.would like to replace it or just remove to see if that was the problem.any other suggestions?

Share this post


Link to post
electricjohn

Maybe your raw water pump got airbound. Does your boat have a seac*ck?

Share this post


Link to post
BARTMAN

two bolts on the t stat housing and turn it upside down and their is a plastic sleeve pushed in on the t stat. usually hard to remove the sleeve so spray it with wd 40 and slowly work it out and go to the parts store and buy a good brand like STANT but you need to use the marine gasket to keep from crushing the retainer plastic sleeve as it sticks out past the housing and down in the intake

Share this post


Link to post
bigeasybu

so it comes out from the bottom? didnt se a plastic sleeve what temperature should i get?

Share this post


Link to post
99response

Sounds like the boat wasn't pulling water, did you look at the sea strainer to verify flow?

Share this post


Link to post
areamike
Sounds like the boat wasn't pulling water, did you look at the sea strainer to verify flow?

Always the first thing to check with temp problems. Water flow. check trainy cooler screen, hoses, water flow etc.

Share this post


Link to post
sunscapeJeff

Have you checked the impeller? You say you never winterize, so I'm guessing as part of that winterization/summerization procedure you're not checking it or replacing it every other year. I bet it's the impeller.

Share this post


Link to post
bigeasybu
Have you checked the impeller? You say you never winterize, so I'm guessing as part of that winterization/summerization procedure you're not checking it or replacing it every other year. I bet it's the impeller.

entire raw water pump pulled and impeller in good shape just reposted updated info have a look

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...