Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Maddox

Bilge Question

Recommended Posts

Maddox

Pulled the boat out and dewinterized last weekend. Been cleaning it up for tomorrow and noticed the bilge no longer works, automatically or by switch. It worked when I put it away for the winter. I also noticed it pops the little white breaker thing (technical term) underneath the switch if I turn on multiple switches at one time. Any thoughts on what is going on?

Share this post


Link to post
jgouveia3
Pulled the boat out and dewinterized last weekend. Been cleaning it up for tomorrow and noticed the bilge no longer works, automatically or by switch. It worked when I put it away for the winter. I also noticed it pops the little white breaker thing (technical term) underneath the switch if I turn on multiple switches at one time. Any thoughts on what is going on?

there must be something stuck on the bilge pump, not allowing the motor to turn, and its putting a load on the circuit

Share this post


Link to post
Maddox

I pulled it apart last night and there is nothing stuck in there. I tried turning it by hand and it seemed pretty stiff. Not sure what resistance it is supposed to have.

Share this post


Link to post
lib135

Just replace it.

Share this post


Link to post
BlastRlxi
Just replace it.

Plus1.gif

Yeah, the bilge pump isn't something I'd fool around with. They're not that expensive and when you need, you NEED it!

Share this post


Link to post
jgouveia3
I pulled it apart last night and there is nothing stuck in there. I tried turning it by hand and it seemed pretty stiff. Not sure what resistance it is supposed to have.

there should be very little resistance. the motor is fried. probably got left on, with no water on it, it overheated. now when you turn it on, it is putting a load on it. time to replace.

Share this post


Link to post
Maddox

10-4, I will go buy one at lunch. It looks the wiring off it runs up under neath the boat. How big of a pain is it to replace. Mounting looks easy, wiring I am not so sure about.

Share this post


Link to post
RTS

Should be pretty easy to wire. The new one will have the same wires as the old one and will come with wiring instructions.

Just be sure to buy some water proof electrical connectors to use...they'll likely have them where you buy the pump.

Edited by rts

Share this post


Link to post
wienrdog

FYI for the connectors - The wiring will be 16 gauge & you'll need 3 connectors.

Mine from the factory just uses the heat-shrink waterproof butt connectors.

The float switch in my pump is gone, so I'm in the process of replacing mine too. Others have covered it, but the pump base is just screwed into the floor of the bilge. If you can't find the same pump, you may need to repair/caulk the existing holes before creating new ones.

Share this post


Link to post
Maddox
FYI for the connectors - The wiring will be 16 gauge & you'll need 3 connectors.

Mine from the factory just uses the heat-shrink waterproof butt connectors.

The float switch in my pump is gone, so I'm in the process of replacing mine too. Others have covered it, but the pump base is just screwed into the floor of the bilge. If you can't find the same pump, you may need to repair/caulk the existing holes before creating new ones.

The waterproof connectors answers my question. Chasing those wires through the floor to get out of the wetness would be a serious pain. So I can just cut it right at the old pump and throw connectors on.

Share this post


Link to post
68Slalom

It wouldn't hurt to use marine silicone to seal the connectors, that's what I normally do :)

Share this post


Link to post
Squag Mon

Supposed to hit 100 degrees in the Tri-Cities Friday. How about on the west side?

Edited by Squag Mon

Share this post


Link to post
crescentbar
Supposed to hit 100 degrees in the Tri-Cities Friday. How about on the west side?

The sun just came out here today. We are supposed to get up to 87 this weekend. Yahoo.gif

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...