Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
tapenick

Info on fix for Pertronix Issue

Recommended Posts

tapenick

FYI - Installed a Pertronix in my 85 Skier (PCM 351, Prestolite clip down) and had some issues at high RPMs. Sometimes it would stutter like it was crossfiring and sometimes it would surge like a fuel issue. After debugging with the help of Pertronix it turns out the air gap between the module and the magnet was too much. Easy fix - drilled out one rivet holding the module and 'swung' the module closer to the magnet.

Share this post


Link to post
TRBenj

I know several people who have had the exact problems you describe with Pertronix kits. Care to share the proper gap spec with us?

Share this post


Link to post
tapenick
I know several people who have had the exact problems you describe with Pertronix kits. Care to share the proper gap spec with us?

Should be .020 - .030. Mine was .076. Easy fix since the plate, mount are aluminum. Drill one rivet out, insert feeler guage, swing module snug with feeler, mark, drill, insert screw.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...