Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

speedometor just went dead


Recommended Posts

Hey there,

Does anyone know how to trouble shoot or repair a speedometer? Ihave dual speedometers and one just went dead on me. I'd like to fix or repair it and don't really where to start? Does anyone have experience with this item? Thanks Euro1

Link to comment

Probably just got some weeds in the pitot tube for the speedo that went dead. My lake has a lot of weeds and if I just put it in reverse for a moment or two it usually clears.

Link to comment

I've got an '04 and the connections under the dash were sketchy on some of my gauges. Once they were reconencted correctly I haven't had any gauge issues.

- Basically stick your head under there and check the connections coming off that gauge. Test them if you can.

Link to comment

I am curious about this, I have a 99 sunsetter LX since purchasing this 4 years ago, I have only had one pick up working. I have switched tubes, ruling out the pitot, and now one will peg to 60 and the other is so slow on the pick up. IDEAS??

I've got an '04 and the connections under the dash were sketchy on some of my gauges. Once they were reconencted correctly I haven't had any gauge issues.

- Basically stick your head under there and check the connections coming off that gauge. Test them if you can.

Link to comment
Probably just got some weeds in the pitot tube for the speedo that went dead. My lake has a lot of weeds and if I just put it in reverse for a moment or two it usually clears.

Plus1.gif on the clogged tube. Try using a bent paper clip to clean them out if something is stuck in there.

Link to comment
I am curious about this, I have a 99 sunsetter LX since purchasing this 4 years ago, I have only had one pick up working. I have switched tubes, ruling out the pitot, and now one will peg to 60 and the other is so slow on the pick up. IDEAS??
I've got an '04 and the connections under the dash were sketchy on some of my gauges. Once they were reconencted correctly I haven't had any gauge issues.

- Basically stick your head under there and check the connections coming off that gauge. Test them if you can.

Is the side that's pegging to 60 the side that wasn't working at all before? Maybe the previous owner tried using the adjustment on the speedo when it stopped working. Have you played with the adjusting arrows?

My guess is the slow pickup is likely caused by a partially clogged tube.

Link to comment

Thanks,

I will clear them tonight and see if it makes a difference!

I am curious about this, I have a 99 sunsetter LX since purchasing this 4 years ago, I have only had one pick up working. I have switched tubes, ruling out the pitot, and now one will peg to 60 and the other is so slow on the pick up. IDEAS??
I've got an '04 and the connections under the dash were sketchy on some of my gauges. Once they were reconencted correctly I haven't had any gauge issues.

- Basically stick your head under there and check the connections coming off that gauge. Test them if you can.

Is the side that's pegging to 60 the side that wasn't working at all before? Maybe the previous owner tried using the adjustment on the speedo when it stopped working. Have you played with the adjusting arrows?

My guess is the slow pickup is likely caused by a partially clogged tube.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...