Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

  • Recent Posts

    • agarabaghi

      Posted

      Do these engines have MAFs or MAPs? 2019 model. 

    • SlingShot

      Posted

      Replaced mine last year.  It is a complete unit with the wire attached.  At least on mine, the paddle assy also has the lake temp sensor in it.  If you cut the wire and solder, I think you would need to recalibrate the temp.  Even possible???

      just gary is correct, you can buy a paddle wheel service kit.  (Bakes, Great Lakes Skipper...etc)  Comes with he paddle wheel and a replacement o-ring.  If your housing is reusable, its much cheaper way to go.

      If you get the complete replacement, use the old wire as a "fish" to pull the new one through with.  Tape it to the end and carefully pull it through.

      • Like 1
    • Charlotte2

      Posted

      On 24/08/2016 at 03:11, MadMan said:

      Le mien a également bondi jusqu'à ce que je jette par la fenêtre la gamme de paramètres recommandés par Perfect Passes. Terminé avec KDW - 410, NN -66. Pas de flambée même avec l'hélice 14 x18 et le surf ballast de 3200 lb. Pas de wakeboard en hausse non plus.

      hello.. what your boat ? kdw ? thank 

       

    • NoahDayne

      Posted

      1 actuator stopped working. I can get the motor but a clicking inside so pretty sure it is a gear... Are there any web sites for parts or actuators? Possibly other member that motor went out and has the gears? 

      Thanks All

    • camcruiser13

      Posted

      we had an 04 we put a g3 tower on  dont ask why????

       

      friend towed it up to the lake forgot how tall it was with a tower and went under an overpass to low,  insurance bought a nice new one and thats when we upgraded,  hahaha

  • Latest Classifieds

  • Recent Status Updates

    • GaryB

      GaryB  »  Woodski

      Looking for a little more top end on our 97 Sunsetter LX.  Don't get me wrong, we have a good running 320 monsoon MPI.  540  hours. This is our family sized barefoot boat, we foot it every weekend,  slaloim ski at 30 and, anchor it in the coves in the afternoon. \
      That being said:   Acme 525, full tank of fuel and 4 souls aboard gets 45.9 mph (stargazer) at wot, engine is turning 5050 rpm. 
      One longline barefooter is good for 44.7, two longline footers 43.5,  rpms are all still right above 5000. My footing partner would like a little more top end for one foots. His height to mass ratio and shoe size are a little different than mine... he is also a very capable footer who executes aggressive wake crossings. 
       
      I was reading about the option to add some timing, according to some other posts on this forum,  the base timing is 10 btdc  and the computer will add up to 20 more degrees of advance.  All in at 30 degrees.  more timing should increase torque.  
       
      Do you know anyone who has done this? any other feedback? 
       
      Thanks
       
      Gary 
      · 4 replies
    • obski

      obski

      Finally got out for a ski on Saturday.  Good grief, it's already August.
      · 0 replies
    • SandpointDave

      SandpointDave  »  Patrick

      Did you figure out your issue with your boat? Mine is doing the same thing and it is driving me crazy. Any help would be great. Thanks 
      · 0 replies
    • SandpointDave

      SandpointDave  »  LiquidCourage

      Did you resolve your issue? My boat is doing the same thing. Already changed the filter and it seemed to help for a bit but to no avail. The boat still cuts out when it is hot and over 2900. Thanks for your reply. 
      · 0 replies
    • toddington247

      toddington247

      First, thanks for all the help.
      She started acting up again and I figured out it was loosing power to the fuel pump. 
      Changed out the fuel pump relay and problem solved.
      Thanks again.
      · 0 replies
  • Recent Topics

  • Latest Images

×
×
  • Create New...