Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Maliview touch screen replacement....help please.


Recommended Posts

Same here...my screen is still working but I think it will need to be replaced sometime during summer 2021 as it has delaminated significantly.  Anyone have any luck repairing the screen?

Link to post
  • 2 weeks later...
  • Replies 83
  • Created
  • Last Reply

Top Posters In This Topic

  • COOP

    11

  • DAI

    7

  • oldjeep

    5

  • QmanBu

    5

Top Posters In This Topic

Popular Posts

take a look at the attached thread, start at page 9. You can replace your MTC with a switch bank for probably less than $200. This rids you of the MTC issue once and for all.   

If Bakes has it I would call and see if its one from the newest batch (past 4 months or so). Supposedly the newest batch uses a different supplier for the build parts to avoid the screen delam issues.

If its coming from Malibu it should be a new batch.  It should also have the latest software. The last one I ordered was built in Dec. and they had no more of the old ones.

Posted Images

I fell like I have heard of some sort of cable that creates a jump that allows the boat to be started to at least get you home if your out. Does any know what I'm talking about or did I dream it? (very possible)

 

also where can I find info about the key switch override?

 

I'm just looking for a fail safe because my screen is starting to go (pic included). I'm going to buy a new screen but trying to hold off as long as possible. img%5D

Link to post
  • 3 weeks later...
On 12/30/2020 at 8:40 AM, Chris said:

were you able to rebuild  or repair the delam screens? my 14 LSV still works, but I'm hoping to fix it before it dies. 

Hey All -- Sorry for the lack of follow-up.  I obviously don't check in often enough during the offseason.  I didn't have any success with repairing the screens.  The way that the digitizer is laminated to the glass is (from everything I've tried) completely unable to be separated without destroying the unit.  A friend of mine has a business repairing digital screens and after I struck out I went and visited his facility. We employed both heat and cold to try and get them apart and only caused more damage.

Link to post
  • 3 months later...
noeffort

I have a 2013 23LSV, middle upper screen, maliview with the side buttons, it started to get fuzzy at the lake last Sunday.  Within a hour the screen was unreadable as in scrambled , but everything else worked.   Boat was powered down then  up at the lake after problem and it started normal but then went scrambled dark with in seconds.   
Could this be just an input problem? Once home I did check all the connections I could see under the dash and one seemed loose, I turned it back on and it worked normal  for about 10 minutes (then I turned it off).  

 

thanks,

Jud

Link to post
11 minutes ago, noeffort said:

I have a 2013 23LSV, middle upper screen, maliview with the side buttons, it started to get fuzzy at the lake last Sunday.  Within a hour the screen was unreadable as in scrambled , but everything else worked.   Boat was powered down then  up at the lake after problem and it started normal but then went scrambled dark with in seconds.   
Could this be just an input problem? Once home I did check all the connections I could see under the dash and one seemed loose, I turned it back on and it worked normal  for about 10 minutes (then I turned it off).  

 

thanks,

Jud

That screen on my 2012 has a similiar issue and when I take the dash panel off and reseat the RCA connector it goes away.  I keep meaning to figure out how long that cable is and replace it with a gold one.

Link to post

I have a 2013 VLX and the Maliview screen was flickering last year; realized the dash was loose, likely causing the connection issue. Any tipcs/instructions on how to remove/replace the dash w/o breaking anything?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...