Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Search the Community

Showing results for tags 'throttle'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Website News, Announcements & Feedback
    • Website Announcements
    • Website Feedback & Support
  • Discussions
    • Malibu Boats - General Discussion Area
    • Axis Wake Boats
    • Watersports & Gear
    • Modifications & Accessories
    • Trailers & Tow Rigs
    • Ballast Info & How-to
    • Stereo Info & How-To
    • Maintenance, Tech Info & Troubleshooting
    • Tech & DIY Article Discussions
  • TheMalibuCrew On & Off the Water
    • Events
  • Classifieds, Deals & Discounts
    • Classifieds
    • Want To Buy / Post a Freebie
    • TheMalibuCrew Store
    • Deal Street
  • Group Buys
    • Group Buy Requests
    • Group Buys For All Members
    • Group Buys For Paid Members

Product Groups

  • Subscription Packages
  • MalibuCrew Gear
  • Other

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 3 results

  1. I have an 06' V-Ride, same hull as 2004 and older VLX. I'm trying to replace the Morse shifter assembly. I can find the ones with both transmission and throttle cables but I can't find a semi digital? The one that's currently on has a throttle cable and an electric plug for the trans. Can't find a direct link to Morse. Local dealer saw it and said they couldn't locate a part number for it?
  2. I picked my boat last night and I'm crawling through her. The throttle seems to have no tension on it? Very easy to move forward and reverse. Is there a way to tighten the tension?
  3. Newbie here, I have spent nights reading a lot of great posts about maintenance and educational tips. Definitely worth the $ to support the Crew and save big bucks down the road. On my 2004 LSV monsoon 340 I replaced the perfect pass cable mid season last year and I must have missed a step because now the throttle linkage unscrews itself and the motor goes to idle until I reattach the linkage. Wife is not happy when it happened while skiing. I am thinking I missed a lock nut somewhere. It separates right under the bracket that holds the perfect pass cable and the 6" long throttle rod linkage. The 1" long brass nut unscrews itself from the threaded silver linkage just underneath it, right near the pop up ski pylon. I have attached a couple of pictures. I was hoping somebody could look at their set up and see what I missed if anything. Tempted to put Lock tite on it after I set the idle. Any other suggestions would be much appreciated.
×
×
  • Create New...