Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Search the Community

Showing results for tags 'maintenance'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Website Announcements & Feedback
    • Website Announcements
    • Website Feedback & Support
  • Discussions
    • Malibu Boats - General Discussion Area
    • Axis Wake Boats
    • Watersports & Gear
    • Modifications & Accessories
    • Boat Storage
    • Trailers & Tow Rigs
    • Ballast Info & How-to
    • Stereo Info & How-To
    • Maintenance, Tech Info & Troubleshooting
    • DIY Articles
  • TheMalibuCrew On & Off the Water
    • Events
  • Classifieds, Deals & Discounts
    • Classifieds
    • Want To Buy / Post a Freebie
    • Supporter Discounts and Group Buys
    • Group Buys For All Members
    • Group Buy Requests
    • Deal Street

Product Groups

  • Subscription Packages
  • MalibuCrew Gear
  • Other

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 5 results

  1. Hi All, I’ve looked through everything I can and can’t find an answer so sorry in advance if it has already been covered. Has anyone installed and INDMAR sea strainer pro on a V drive boat? I’ve got a 2003 21’ LSV Sunscape and I’m looking for install advice and if possible. The strainer comes either straight through or a 90 at the inlet. I was thinking I can go the 90 style straight out of the ball valve at the pick up, lay it horizontal towards the back then curl a hose back. I was thinking this would also allow for easy inspection and maintenance. I was then going to insta
  2. Two mounting brackets and brackets that attach to my ski deck are either broken or close to it. I'm looking for creative (and cost effective) replacement solutions. Has anyone been in this situation and used a company that specializes in extruded plastic? OEM markets show the replacements are now aluminum. I'm looking into whether a 3-D printer option is strong enough or not.
  3. Any help is welcome and much needed! Boat ran like a top yesterday on the water, and today boat would not start. When key is moved to the accessory position it doesn't even beep. No sound, nothing, just dead. Tried to turn the blower, the bilge and the radio on and nothing from any of the accessories. Checked the batteries and they read fully charged with 12.7 V. Tried resetting all of the breakers and disconnecting and reconnecting all the cables. (Have not tested w/ multimeter). Ensured everything on the battery end and CB ends were securely mounted. I assume maybe a bad breaker? But wo
  4. Hi All - I need to replace the thermostat on my 2005 Malibu Response this spring. I have an LCR 320 and have the correct gasket and thermostat in hand that I purchased from Skidim. With that being said I'm trying to research on how to do this properly. I've done some googling and tried to watched a few videos but I haven't found anything that seems similar to my boat / engine model. Anybody have anything I should check out? Also, which gasket sealant should I use? I know that I'll have to use a chisel to get the old gasket off from what I hear but I was curious if there is more to the pr
  5. Our 2009 Response FXi has an Illusion XS tower which, aside from a few design flaws, is an excellent tower. However over the last couple years it developed a creak sound under high load (pulling up riders). Upon inspection, we found one of the two pin bores in the base of the tower to be worn oval, when it should be circular. This seems to allow for additional play/slop at the pivot point. The creaking sound is not pleasant nor reassuring so we’d like to fix it as soon as possible. Has anyone else experienced this and if so, what was the fix? Thanks! Mark
×
×
  • Create New...