Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

2011 vlx speedometer and lake temp not reading


Recommended Posts

TQdubb

I recently purchased a 2011 vlx and the speedometer isn't working on both the analog gage and the maliview screen.  The lake temp also indicates 32 degrees F.  The paddle wheel unit includes a temp sensor.  I measured for 12 volts to the paddle wheel and it isn't there.  Any ideas if there is a fuse that feeds it and where it might be located?  The sensor is brand new!  TIA

Link to comment

The water temperature data is usually supplied by the depth transducer and will only use analog temperature data through a blue/white or blue/black wire from the paddlewheel sensor to the dash Viper connector if there is no depth transducer.  Verify that the ground connection for the paddlewheel connector is good.  Speed and depth sensors are connected to the engine harness and the data is sent from the sensors to the engine ECM to the dash Viper controller through the Controller Area Network.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...