Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Recommended Posts

Pipelayer

Pulled into the marina after a 30 minute ride, and once I went to neutral and back into forward the tranny went into reverse.....opened the hatch and noticed the V-drive d & transmission dipsticks are both melted. The boat was just serviced in Vegas at Tommys (now out of business) 3-4 weeks ago. When I first got it back from service we almost sank because the tech didn't put the front plate back on the impeller. So im thinking the overheat problem is their mess up also. Any ideas on why they both got so hot? wrong fluids? not enough fluids? Are they toast? How screwed am i?

  • Sad 2
Link to comment

I'm pretty sure for your year the motor is closed cooled, but the trans and v-drive are cooled by raw water..... so if the impeller is not there/ working properly... they aren't getting cooled. Yikes. Wonder if when they put the impeller cover back on, they didn't put an impeller in there.... 

Edited by BlindSquirrel
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...