Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

340 monsoon issue


Recommended Posts

Hey crew… need some thoughts from you all.  I have an 07 23 LSV with the 340 monsoon.   The issue I am having is when you get on the throttle hard and you get on plain I get a service engine code and it cuts the throttle/ power.  When I bring it back to idle spend and go up on plain slowly it does not give me the code.  Only when I get on the throttle hard.  Could this be a throttle sensor issue?  The boat was not weighted.  Your thoughts appreciated!  Thanks Mac

Link to comment

It is not giving me a specific code…should have clarified that..sorry…it is just coming up on my screen to service engine.  By hitting the E (option) button on my screen it clears the service engine until I throttle up hard again.  Then service engine comes up on the screen. Does that make sense?  Will a dealer be able to read the code even if it does not say service engine on the screen?

Link to comment
Posted (edited)

To see any active or inactive codes using the 2007 Malibu Info Center display, use the up down buttons to scroll to the Setup menu and press E, scroll down and select Service, and select Fault Codes.  Rinda Diacom or TechMate can also be used to read fault codes.

Edited by csleaver
Link to comment
Wrex0215

I had the same problem, ended up being a voltage issue. 1 of my 3 batteries went bad, replaced it and it was good to go!

Link to comment

I just got off the water and had the same issue.  We typically don't run much over 32 (our slalom speed) but when taking it up to full throttle, it just cut out and went to idle.  I too was able to clear the "engine fault" or "service required" on the readout and continue running.  Fine at all speeds other than wide open.  I saw something about possible issue with the two stage fuel pump???

Just replace the battery this spring.

I will have to check fault codes as described above after this storm passes.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...