Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Plug n play ballast fittings popping off


HBsurf

Recommended Posts

I have a 2021 Axis A22. The rear plug n play ballast bags’ fittings (attaching the bottom (empty) hose connector), keep popping off, when the bags are full. Auto bilge comes on, I look, and sure enough water is pouring out of the bags.

It happened within the first 50 hours of use, and I’ve had the dealer install new fittings, and now it’s happening again, less than a year later.

it’s just a plastic lock ring that holds the hose connection in place, holding hundreds of pounds of sloshing water… so I’m leery this is just going to keep happening.

Anyone else having this issue?

 

Edited by HBsurf
Link to comment
Imcalmerthanyou

This happened to me multiple times within the first 15 hours of having my 2022 A24. I figured out that the bag was sitting a little wonky in the locker so when it filled it was pulling the connector apart. 
 

I played with the lie of the bag and eventually got it to stop. I’m only at 45 hours but it hasn’t happened since. 
 

Hope this helps. 

Link to comment
4 minutes ago, Imcalmerthanyou said:

This happened to me multiple times within the first 15 hours of having my 2022 A24. I figured out that the bag was sitting a little wonky in the locker so when it filled it was pulling the connector apart. 
 

I played with the lie of the bag and eventually got it to stop. I’m only at 45 hours but it hasn’t happened since. 
 

Hope this helps. 

I’ll second that. Exact same thing happened to me in my previous boat. It was a Supreme S202, but either way, the port side rear ballast bag was off center and popped the hose fitting almost every time. 

Link to comment

I have had some success in preventing the flow-rite quick connect fittings from coming loose by putting a regular 8 inch zip tie around just the little black plastic flexible upper part of the fitting, right behind the red plastic sliding lock.  Sounds confusing, but I can't think of a better way to describe it and I don't have a good picture of it.

Link to comment

I've had the same issue.  Two things that I did to prevent this or at least minimize the frequency is to make sure the empty bag is in a good location prior to filling bag.  This will minimize the stress forced to detach underway.  Also, I don't totally fill my 550 lb bag.  That's the wonderful advantage of the Power wedge 3.  Position 3 is my standard wedge setting, but will set to 4 occasionally and this is the same as adding additional gallons of water to the bags.  Simple solution for a beautiful wave.   

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...