Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Did anyone face this before?


Recommended Posts

WilliamCh

Hello guys, need some help with my new A20, my engine turns off whenever I return the gear in Neutral. Boat is running smoothly, everything is okay, but whenever i turn the throttle to N (RPM goes slowly to 0 and engine shuts down) but turns on again normally when I do turn it on. I cleaned the Air filter and cleaned everything around it , it worked normally for a week or so. Today I've had the same issue again. Anyone has a permanent solution for this. (No error codes or miss-fires or anything like that)

 

 

Link to comment
PopsA22

You most likely have an electrical issue related to your neutral safety switch.  Sorry that doesn't help solve your problem but hopefully you can find a good boat mechanic in Dubai.  

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...