Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Screen glitching … help please


Recommended Posts

KnotOnCall

Our 2022 lsv23 we picked  up early April started having screen glitching the second time we used it. It progressively got worse with cutting out completely twice. There were also times the on/off switch stopped working and also surf gates not working either at times…. But not every time. Our dealer took it in and replaced a cable but it only seemed to help the first few times we went out. Last night we took it out and screen was glitching again, surf gates not working and on/off switch also not working. We had to use the ‘debug’ setting to get the surf gates  out so we could surf last night. This is getting very frustrating. Has anyone had a similar situation? We are not using the ‘key’ to the boat… as that has apparently been associated with similar issues. Help!!!

Link to comment
1 hour ago, KnotOnCall said:

Our 2022 lsv23 we picked  up early April started having screen glitching the second time we used it. It progressively got worse with cutting out completely twice. There were also times the on/off switch stopped working and also surf gates not working either at times…. But not every time. Our dealer took it in and replaced a cable but it only seemed to help the first few times we went out. Last night we took it out and screen was glitching again, surf gates not working and on/off switch also not working. We had to use the ‘debug’ setting to get the surf gates  out so we could surf last night. This is getting very frustrating. Has anyone had a similar situation? We are not using the ‘key’ to the boat… as that has apparently been associated with similar issues. Help!!!

That's such a bummer.  I would say your dealer needs to put it on the water, spend some time running it and figure it out. 

Link to comment

Have you turned the battery switch fully off and on?  I have noted several times that the computer systems seem to act up when the batteries are not cycled.  FWIW, when we trailer the boat or park it at the dock for the night, the batteries are turned off.

Link to comment
KnotOnCall
39 minutes ago, gahvey said:

Have you turned the battery switch fully off and on?  I have noted several times that the computer systems seem to act up when the batteries are not cycled.  FWIW, when we trailer the boat or park it at the dock for the night, the batteries are turned off.

Yes we turn the battery completely off after each use

Link to comment

Loose connections on the battery cables, power post, or engine ground stud are what I often find cause most electrical issues.

Link to comment
On 6/8/2022 at 9:02 AM, KnotOnCall said:

Our 2022 lsv23 we picked  up early April started having screen glitching the second time we used it. It progressively got worse with cutting out completely twice. There were also times the on/off switch stopped working and also surf gates not working either at times…. But not every time. Our dealer took it in and replaced a cable but it only seemed to help the first few times we went out. Last night we took it out and screen was glitching again, surf gates not working and on/off switch also not working. We had to use the ‘debug’ setting to get the surf gates  out so we could surf last night. This is getting very frustrating. Has anyone had a similar situation? We are not using the ‘key’ to the boat… as that has apparently been associated with similar issues. Help!!!

@KnotOnCall I have a friend having similar issues with 2022 23lsv.  Reply and let us know if/when you find out what is going on.

Link to comment
On 6/8/2022 at 10:32 PM, csleaver said:

Loose connections on the battery cables, power post, or engine ground stud are what I often find cause most electrical issues.

This sounds about right - I vaguely remember someone on here having issues with powered systems, and eventually discovered a bad ground.  Since the dealer has looked at it once, it is possible they haven't done full investigation.  It would probably be worth checking them all out (if you are up to it), or asking the dealer to investigate them for you.

Link to comment
On 6/8/2022 at 9:32 PM, csleaver said:

Loose connections on the battery cables, power post, or engine ground stud are what I often find cause most electrical issues.

Great call on checking the ground! 

Link to comment

Once you've checked all of the grounds, battery and alternator cables.

IF this also correlates with high temps, I added a (small, raspberry pi size) heat sink to the regulator for my display (2006 precision pro Malibu information center) and it prevented glitching (an empty display or shifting lines)

 

Link to comment
KnotOnCall

Thanks… i forwarded your responses to the dealer. They picked it up today but really it seems they have no clue why it is doing this. Hopefully this will help

Link to comment
KnotOnCall

@klntime so far the dealer has checked all connections, replaced a ‘harness’ and another cord of some type with no improvement. Malibu is now telling them to replace the screen but it is backordered. Has your friend had any luck? This is getting old. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...