Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Navigation and anchor lights not working properly - T22 2020


Recommended Posts

Mjaxis

I was hoping someone might know of the problem or could point me the direction to start trouble shooting  (before I pull things a part).

According to the manual, if you press the button once you get nav lights, second time you get anchor lights, and third time is nav and anchor. 

when I press mine once I get nothing, twice i get nav, and third time i also just get nav.  The anchor light never comes on.   
 

any ideas?

 

thanks!!

 

Link to comment

See if the anchor light harness is plugged in where the harness goes up the starboard side of the tower.  Twist to remove the LED light on the tower, pull on the wires to see if they are still connected to the harness.

Link to comment
Mjaxis

Is the harness behind the throttle panel?  
 

I did pull on the wires from the top and they seemed connected…. Only so much came out. 

Link to comment

There should be a harness plug just below where the tower mounts to the starboard side of the boat.  It will have a black/yellow wire and red wire with a small label that says "Anchor Lt".

Link to comment
Mjaxis

Just found it. It was connect, but I unplugged it, checked for dirt/contamination and put it back together.  Still same issue. 

Link to comment
Posted (edited)

If all of the wiring and connections are good then the Info Center controller may not be sending the ground signal to that circuit.  It has a solid state internal switching device for the ground that makes the anchor light turn on and off.  You can use a volt meter to test for power and ground at the connection near the tower or at the main dash harness plug to confirm that.  Also check the power modules and their fuses under the dash.  I can remember if the anchor light is fused at the power module or not.

Edited by csleaver
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...