Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

2004 23 lsv losing power after running 20-30 min


Recommended Posts

Just bought this new to me 2004 Malibu 23 lsv.  Took it out on the lake this afternoon- ran great for -about 30 min the started losing power acting like it was going to cut off.  I would throttle back for a few seconds and it would regain power again as I gave it the throttle.  Happened twice today- about an hour apart.   
I am going to get the dealer to look at it Monday, but just curious if anyone has had the same issue.  
Thanks

Link to comment

Its almost like the engine died, but as I let off the throttle, it would regain power and I could accelerate again.

fuel pump maybe??

Link to comment
Posted (edited)

Had similar issue with 2002 VLX.  Lost lot of power after 30 min like not getting fuel but would go to neutral and be ok again for awhile.  In my case I changed the ECM.  Like new again. 
 

But I’d say worth checking fuel pump/screen as well just in case.  
 

Marc 

Edited by mtagher
Added comments
Link to comment

Marc,

that is pretty much what it is doing with me.  
I am going to take it to the dealership, but at least these answers give me some idea what to expect

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...