Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

"NO DATA" on speedo, 03 RLXi MMDC repair/replace or TRD conversion?


Recommended Posts

 

Dewinterising my australian made 03 Response LXi last night and I think I’ve killed the MMDC doing exactly the same as MadDogMike did. His attempted repair then MMDC replacement discussed in this old thread https://www.themalibucrew.com/index.php?/forums/topic/73209-engine-gauges-inop-no-data-on-speedo-04-vlx/

Had a stressful day at work and life generally been stressful recently so trying to get some balance I collected boat with aim to dewinterise and use it for the first time this season this coming Saturday.

Thinking easy job so I reconnected water hoses, then battery cables to the recently charged battery (1 big red +ve, 1 big black -ve and 1 smaller -ve to amplifier).

With lanyard disconnected I checked engine turned over (all good) with plan to then install impeller and job done ready for Saturday skiing ………but noticed the accessories (blower, heater, lights, etc) all running slow or dim and PerfectPass going nuts beeping and flashing on off. Also noticed the small LCD in the speedo saying NO DATA. Thought maybe battery volts low so used multimeter and all good (12.9V). The multi guage needles wiggle on switch on.

Thought maybe bad earth so got under dash. All looked good but took off and cleaned main -ve cable lug onto busbar anyway. Same.  

Searched TMC and saw MadDogMike thread……… sure enough, I’d neglected the to connect the ‘everything else’ smaller black -ve cable to the battery. We brought the boat end of autumn so this is my first dewinterise of it and the end of the cable was hidden down behind the battery box.

My guess is a backfeed has killed the MMDC and that’s also what took out Mike’s.

Bakes are showing US$1339, then add on shipping and taxes and duty here in New Zealand and it’d be approx US$1900!!!!!  So if me simply not reconnecting the other -ve has killed the MMDC it’s big oopsie. So annoyed at myself.

I’ll email medallion to see what they think. Hopefully they say ‘no problem, do this’ or if not will still sell a MMDC direct for US$500.

If not, I think I’ll be seriously considering one of the TRD conversion kits. Something like this. Not sure exact model. Will email them for pricing and advise.

https://skiboatpartsonline.com/TRD-Conversion-Kit-Medallion-MDC-1600-1/Medallion-Conversion-Kit-Malibu-TRD-1205-MAL-PP

Link to post

@MadDogMike never sent his old one to me.  I said in that thread that it probably was a solder joint, but on thinking about it again, it is more likely a dead transistor.  Either way, it would be a cheap fix if that is all that is wrong.

Does yours have the same dead yellow output wire as Mike had?

Link to post

I've not checked all the pin voltages yet.  Have noticed all the guages now wiggle on turn on but settle on zero so hints no output from anything.

Prior to connectiing the missed battery -ve cable they'ed wiggled then settled on weird values like oil 40psi, 8 volts, temp 130deg. Engine was not running. 

Unplugged and replugged both cables on MDC but no luck.

Tried to remove dash cluster to disconnect each gauge but can't seem to get dash insert out. Removed top screw and two from lower Malibu logo. It's loose at top but it's stuck somewhere on bottom edge. Can't see any other screws or fasteners

Tempted to just say fek it, I'm a fool and made a dumb mistake and buy a TRD kit rather than use hours of non spare time stuck under dash and missing out on summer. Even if I buy TRD kit suspect I'll wait weeks for international shipping

Link to post

Checked the input cable and found

pin 5 is approx 1600 ohms 

pins 8 is not connected to the ground bar

pins 19 and 20 have 0 volts. Not sure how the horn is relevant to the MMDC and it's 5" gauges. The gauges wiggle on power up so seems like servos in them are getting power.

Something very weird going on! Tried to trace the ground wires from pins 5 and 8 wires thinking they're the likely culprits (both actually grey with black stripe, not black with white stripe) but  not much success. One of them goes to the air temperature sensor in the front vent (as the other air temp sensor wire is yellow so matches pin 7) but can't trace the other one. 

 

Link to post

From the MadDogMike thread

MMDC-in 24 pin harness for EFI

Quote

1, FUEL SENDER, 33 TO 240 OHMS, 0 TO 7 VDC, PINK WIRE
2, OIL PRESSURE SENDER, 33 TO 240 OHMS, 0 TO 7 VDC, LIGHT BLUE WIRE
3, SEA TEMP, 10000 OHMS AT 77 DEGREES F, 0 TO 7 VDC, BLUE WITH WHITE STRIPE WIRE
4, NA
5, GROUND, BLACK WITH WHITE STRIPE WIRE
6, ENGINE ECM DATA, ORANGE WIRE
7, AIR TEMP, 10000 OHMS AT 77 DEGREES F, 0 TO 7 VOLTS, YELLOW WIRE
8, SERVO GROUND, BLACK WITH WHITE STRIPE WIRE
9, NA
10, NA
11, IGNITION, 9 TO 16 VDC, PURPLE WIRE
12, BATTERY, 9 TO 16 VDC, RED WIRE
13, INCREASE/DECREASE GROUND, BLACK WITH WHITE WIRE
14, DECREASE SWITCH, 0 TO OPEN OHMS, 0 TO 5 VDC, RED WITH WHITE STRIPE WIRE
15, INCREASE SWITCH, 0 TO OPEN OHMS, 0 TO 5 VDC, BLACK WITH WHITE STRIPE WIRE
16, NA
17, NA
18, NA
19, HORN, 5 TO 11 VDC, BROWN WITH BLUE STRIPE WIRE
20, SERVO POWER, 9 TO 16 VDC, WHITE WITH RED STRIPE WIRE
21, SERVO CONTROL, 0 TO 16 VDC, RED WITH GREG STRIPE WIRE
22, NA
23, PADDLE WHEEL, GREEN WIRE
24, BOAT GROUND, BLACK WIRE

 

Link to post

Ordered a Medallion to TRD gauge conversion kit today as Medallion never even bothered replying to my messages. Their loss.

https://skiboatpartsonline.com/Medallion-Conversion-Kit-Malibu-TRD-1208-MAL-PP?search=1208 

Ron said they're custom made and dispatched in 3-4 days.  International shipping is highly variable at moment so no idea when it'll arrive. Hopefully FedEx delivers fast as!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...