Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

2000 Escape LSV No Gauges and Constant Beep


Recommended Posts

Thrash91019

I have a 2000 Escape LSV.  The boat runs fine, but my gauges all stopped working and when I turn the key to the on position it’s beeps constantly. When the boat is started the beep goes away. I thought it was the MDC computer, but tested that and was fine. Even had a friend with a spare MDC and swapped them. Same result. I have looked everywhere for the inline fuses for the MDC, but can’t find them anywhere. This is my first boat and kind of at a loss on where to go next. Any help would be greatly appreciated!

Link to post
Thrash91019

Thanks. I don’t remember it beeping like that before, but maybe I just ignored it.  These damn gauges tho….

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...