Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Bilge Pump Replacement


Recommended Posts

Need to replace the bilge pump in my Sunsetter, what is the best pump to replace it with? Thank you in advance!

Link to post

I’ve always had good luck with Rule (with a float switch) or Attwood pumps (built in switch)

See Amazon or Walmart for the best prices 

Link to post

I replaced the bilge pump in my '01 SSLXi a few years ago with an Attwood Sahara from Walmart. It fit into the existing base of the original pump.  

Link to post

I just bought my 01 Sportster, bilge is not working,  we’re do I find it to replace?  It was working when I first got it a week ago?

 

Link to post
electricjohn
On 8/13/2021 at 12:50 PM, John I. said:

I replaced the bilge pump in my '01 SSLXi a few years ago with an Attwood Sahara from Walmart. It fit into the existing base of the original pump.  

Same here. But my Winner boat's bilge pump is a 35 year old Rule 500gph that lived in salt water most of it's life. Still going.

Link to post

So what’s the trick to get the plate out.   I took out the two screws.  Pulled on it. Maybe it’s stuck I just don’t want  to break it 

Link to post

i have not had an issue w breaking it loose but getting it out of the bilge was a challenge.

i'd wonder if there are another pair of screws, hiding, that you missed?

Link to post

In my boat the intake hose for the raw water pump interferes with the panel removal. Nothing special to it though - just some screws. Assume you have already checked the fuse, switch and connections to the switch to rule them out?

Link to post

The motor hums.  Not an issue with power to it.  I just can’t break away the panel and I don’t want to break it? Does it pull straight out or is there a lip on the board I don’t see

Link to post

Just went out and looked at mine. No lip just a flat panel. I think it catches on the vents on either side of the bilge if you try to pull it out horizontally. I would suggest removing the hoses from the raw water pump and pull it straight up and out.

Link to post

Just bought an Atwood 1100 from Amazon special price, $75 saved 40$

the plate had 4 screws not 2. Two wer hidden tight in corner. I did remove water hose to Amit easier. Thanks for all the help.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...