Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Engine heating problems


Recommended Posts

Hi everyone, I own 2014 lsv. This summer when I launch from the boat ramp and start the engine, it heats up to 200 degrees within 5 minutes. I turn the engine off, let it cool back down to 150, start again and it stays at 160 the rest of the day. I will even turn engine off and chill for 30 mins on the lake later on, then turn back on and no issues. Only over heats right when I launch. This has happened the past 3 times. Does anyone have ideas of what is going on?

Link to post

first prime can be more difficult to achieve than subsequent starts.

at first launch run the engine rpm up to 1200-1500 rpm for 3 to 5 seconds to insure that the pump primes.

  • Like 3
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...