Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Throttle not engaging 100% of the time going into foward


Recommended Posts

Pstangle86

My throttle occasionally does not go into idle right away. This could become a problem when docking at my launch, since it is tight. It works most of the time. 2013 VTX. Any suggestions?

Link to post

The problem is likely in you ski throttle.  I had mine rebuilt twice. The position sensor is shot.  Its an easy rebuild but Livorsi won't sell you the parts but they do provide a rebuild service.  Of course it's possible it could be elsewhere down the line.

Link to post
Pstangle86

Thanks. So the only solution is to bring it in to be worked on? I will get an appointment.

Link to post
23LSVOwner

I heard Malibu has a replacement for those older throttles now. Might want to check with your dealer to make sure.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...