Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

New M220 ballasts won’t drain

Recommended Posts

Posted (edited)

Have a new M220 and starting yesterday the center and rear ballasts will fill but won’t drain. I’m getting an overcurrent fault in the power modules. If I go into diagnostics I can reset the breaker on the power module but it will dump water for about two seconds and then trip the breaker again. I can push reset 500 times and get all the water out but that’s probably not a great solution. Or good for the boat. The rear lines are not kinked or anything and like I said it fills fine. And it seems to drain fine until the fault happens.  Bow drains and fills fine.

Edited by BZM220
Link to post

It is likely a short to ground in the wiring, faulty pump motors, or a loose connections at the power modules or ground cables.

Link to post

PS the bow drain works and it’s the smaller pump. I’ve only found the center drain and it’s a pentair 2000 (bigger style)

Link to post
Posted (edited)

It is possible there is a software update for it. I recommend checking.

Edited by 23LSVOwner
Link to post

Had mine do this a few weeks back. Remembered my dealer telling me a story about how many issues they were having with pumps due to people changing the boat model in the configuration menu as that controls some of the values in the power modules... Checked it out and during the course of me having the batteries disconnected it had reset to a 22LSV... Changed it back to a M220 and everything worked. I had done a screen reset as well so not sure which one fixed it, but I have not had any issues post changing the model to the correct boat.

Link to post

Wow thank you so much. I had reset to to factory values to fix Bluetooth issues. When I did that it changed the model of the boat just as you said. Changed it to m220 and for whatever reason I also had to turn the battery disconnect off and on again before it all worked properly. But it all works now!!! Thank you!!!!

  • Like 2
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...