Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Rough running and dies


Recommended Posts

Help please! I have a 2003 Malibu Response LXi. Ran great this morning pulling my wife waterskiing with no issues whatsoever. Docked it for several hours and when I started it up to take it out this afternoon, it died.  Got it started and then it wouldn't idle and run. Any ideas on what to check first? (700 hours on the motor. Spark plugs replaced last year. Cap and rotor haven't been replaced for 6 years).

Link to post

UPDATE: Replaced the fuel filter, and runs fine now! Will replace the cap and rotor since it's been so long. Is an inline water separator recommended?

Link to post
7 minutes ago, h20skiers said:

UPDATE: Replaced the fuel filter, and runs fine now! Will replace the cap and rotor since it's been so long. Is an inline water separator recommended?

You might also want to change the plug wires since they are no doubt original.

No need for an inline water separator unless you have inline water....

  • Like 2
  • Haha 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...