Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Ballast Bags won’t fill


MavDax

Recommended Posts

I have a 2007 Wakesetter VLX with rear ballast that won’t fill. When I flip either the Port or Starboard rocker switch, both the fill and drain lights turn red for both sides. I checked the breaker, but they didn’t pop. Marina suggested switching out both piranha fill pumps. I really didn’t feel that was the issue because they spin freely and they don’t even try to start, but did it anyway. No surprise, that didn’t work. The only thing I can think is the breakers are bad, or bad wiring. However the tech said he checked and the wiring to the pumps, and they were fine. If either were bad, it should have shown on the multimeter, right? And why would the fill and drain on both rockers light up at the same time?

Need some help, what’s next?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...