Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Oil psi gauge


Recommended Posts

Badgerski51

2002 Sunsetter LXI oil psi gauge stopped working. Checked oil and all good. It’s the gauge with 4 readings. The other 3 work, fuel, volt, and temp.  What should I check? 

Link to post
Posted (edited)
20 minutes ago, Badgerski51 said:

2002 Sunsetter LXI oil psi gauge stopped working. Checked oil and all good. It’s the gauge with 4 readings. The other 3 work, fuel, volt, and temp.  What should I check? 

check the sending unit.  It's the one that looks like this.  (brass part)

48461b99.jpg

Check that the wiring is in good shape.  If that's fine, you might need to replace the unit.  Be careful removing it.  It's very easy to crack the tube it's mounted to.  When I replaced mine last year, I did so by holding the T fitting with a channel locks while I turned the old sender out in the opposite direction.  Easy to fix.  I used this one.

https://www.amazon.com/gp/product/B07SHSK76H/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

 

Edited by UWSkier
Link to post

Go to any auto parts store with the picture ant tell them it is for a GM 350….  ‘78 Camero, ‘92 Suburban.  They will know the part.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...