Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Nav lights? Stuck on. 06


Recommended Posts

100% pure rookie. First post even. I searched and seen one post talk about a 2015, but mine is a 2006.

 

my nav lights are stuck on. The 8 or so lights on the tower? The switch on the panel is off or in the middle. Not up or down any help?

Lights were off woke up this morning and now they are on  it did rain last night  don’t know if that info matters 

again pure noob rookie.

thanks

Link to post
6 minutes ago, Z06 said:

100% pure rookie. First post even. I searched and seen one post talk about a 2015, but mine is a 2006.

 

my nav lights are stuck on. The 8 or so lights on the tower? The switch on the panel is off or in the middle. Not up or down any help?

Lights were off woke up this morning and now they are on  it did rain last night  don’t know if that info matters 

again pure noob rookie.

thanks

Welcome to the crew!

I have seen switches that short out inside due to water intrusion.  Check with a meter to see if power is on that circuit even though the switch is off.  Confirm by removing the wire to make the lights go off. 

You should be able to pop the rocker out of the switch (go slowly so you can catch the spring and toggle inside) and clean the contacts.  Alternatively, a blast of WD-40 inside the switch past the rocker might remove the water for you.

Link to post

Thanks. I’ll post a pic of it soon. Excited for the year for sure. 
 

super upsetting that we picked up the boat last night. I’ve had it less than 24hrs and already hit with a small tiny issue. It’s ok tho.

anyways.. I completely removed the nav/anc switch and the lights are still on. Are these lights I’m talking about called nav lights?

Link to post

Nav lights are the green/red at the bow and white anchor at the highest point.  Keep checking switches.

Link to post

Well, look at that!  And broad daylight, too!

Tower lights, perhaps?  Do you have a separate switch for them that might be slightly hidden?

Link to post
Posted (edited)

Sure helps calling parts the correct name. Rookie ness showing. The wiring is a nightmare underneath. So many splices that have been cut off. 

I have one switch ACC that does not turn red when I flip it. Disconnected all wires and tower lights are still on so I don’t think they are affiliated with it anyways.

I feel like there would be a hidden switch for them like you said but I’m not seeing anything at all

Are these lights factory lights? If I could find the brand then maybe I could see what color wires to try to find and trace 

Edited by Z06
Link to post

Hopefully someone else can help.  I'm not familiar with that boat, but I'm almost positive they are not factory installed. 

I would expect the wires to come out of the tower at the base on the driver's side.  Look under the gunwale to see what is there and trace it. 

Link to post

Daylight got the best of me today without fully fixing the issue. 
 

I ended up noticing a grounding block. One main ground with 4 slots of grounds. Spot 3 had 2 grounds and spot 4 had 2 grounds into it. When I removed spot 3 with 2 grounds half the lights turned off. When I removed spot 4 with 2 grounds the other half turned off..

im not sure if the lights are wired 2 lights per 1 ground wire or what. I’m definitely making some Progress tho. The hot should be close by like you said and I’ll trace from there. Main thing is I got the lights off without disconnecting the batteries. Thanks for the replies and helping me think. 

Link to post

I still think you have a switch on somewhere that you haven't noticed yet.

Honestly, it is a really good idea to just crawl under the dash and clean every connection you can find, then spray them all with light spray oil to keep oxygen out.  Do all of the bus bars and other connectors you can find.  You may also discover things that will help solve this mystery.

Link to post

I haven’t 100% fixed the issue yet, but I’m close.

I lucked out and found the light wires leaving the tower. The red hot and black ground turn into. 2 black! 
 

The 2 black run under the steering wheel and branch into a nice grounding block and into a questionable fuse setup. IMO it looks like an overkill for basic tower lights. Might be a boat thing idk.

from the fuse setup it runs into 2 relays then a black wire runs to a switch on the control panel. The switch also controls the two lights on the front of the boat. The switch works perfect for those so I’m guessing the switch is fine.

power is working the lights are on. The grounds turn the lights off disconnected. The switch is working for the two lights on the front. The next thing I’m going to look at are the two relays. I find it very odd that both relays would mess up at the same time. I feel that I am close tho and happy I found these black wires

Link to post

Fixed!

it was frustrating but I figured it out. Still confused about it.

the issue was the switch. It is basic, 3 prongs. Power, ground, lights. The lights prong has 3 wires. 2 for the tower lights and 1 for the lights on front of the boat stacked on top of each other. All I did was disconnect the wires knock or any debris with my wind. 
 

the crazy thing is the front lights functioned properly and the tower lights had an issue all connected to the exact same prong. It even went tower light on the main branch to the other tower and the boat light at the bottom. Anyways it’s fixed thanks justgary for picking my brain and helping me through this. 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...