Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

2013 Malibu Tower Lights Flickers on and off twice then stays off.


Recommended Posts

Hello all I just bought a 2013 Malibu 21 VLX so I am excited to be part of the Malibu Family! I have an issue right now with the tower lights and I am still trying to familiarize myself with the Boat but there are two lights shining forward and two lights shining back and two of them will turn on for a couple of seconds then turn off, then turn back on again for a couple of seconds and then turn off and stay off. I have replaced the bulbs and it still does the same thing and I tested the power to the lights and it does the same thing so I know its not the bulbs, I am guessing its the wiring but the on and off of the lights is almost like it is timed and then it stays off so it tells me it might be a relay or something. Has anyone encountered an issue similar to this? Any feedback is appreciated. Thanks. 

Link to post
On 4/19/2021 at 5:01 PM, droc62 said:

...so it tells me it might be a relay or something.

That was my first thought.  When you say you tested the lights and they have power going to them, what exactly did you do?

Link to post
On 4/23/2021 at 4:06 PM, formulaben said:

That was my first thought.  When you say you tested the lights and they have power going to them, what exactly did you do?

 

On 4/23/2021 at 4:06 PM, formulaben said:

That was my first thought.  When you say you tested the lights and they have power going to them, what exactly did you do?

I removed the bulb and used a test light to see if it had power going to the terminals that the bulb plugs into and it does by the power is intermittent where it is on then off then on again then goes off and stays off. So I am not too sure where to go from here. 

Link to post

Doesn’t the ignition have to be on for the tower lights to operate? (Just making sure you tried when the engine was running).... seems like I remember my 2010 flickered when I turned them on without the engine running...the MUX actually turns them back off.   Can’t remember when I last used mine though.  

Link to post

You might be correct, I was just trying them without the engine running and maybe without the full 12v-14v going to the light and the MUX they won't stay on. I will try them when I take it out for the first time. Just waiting for good weather. Thanks for the responses I appreciate it. 

Link to post
15 hours ago, jtrezon said:

Doesn’t the ignition have to be on for the tower lights to operate? (Just making sure you tried when the engine was running).... seems like I remember my 2010 flickered when I turned them on without the engine running...the MUX actually turns them back off.   Can’t remember when I last used mine though.

If those are the halogen ones, then that's a great feature to keep you from draining your battery, as I see tower lights on during the daytime a lot.

Link to post

Looks like that is what it was. I ran it in my driveway this past weekend and they came on and stayed on when the engine was running. Thanks again for the responses.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...