Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Wedge actuators won't shut off on 2009 LSV


Recommended Posts

First outing of the season and the resettable fuse tripped several times when trying to deploy the power wedge and I noticed a small puff of smoke from the fuse panel (bad sign).

One wedge actuator was shot, so off to the shop and had both actuators replaced with the newer style.

Picked up the boat and they couldn't get the actuators to shut off when there was power to them so we tried reversing the wires and same story except this time they kept powering when fully deployed.  He tried adjusting the sensor but no luck. The shop checked with other shops and no one had encountered this issue.  Ordered a new controller, but they sent a different one that would not connect with the wiring harness.   Thinking of just wiring a separate controller to the actuators since the position display still works.

Any ideas?  Is there something that is part of the fuse panel (like a relay) that could have shorted out (puff of smoke) and now provides full time power to the wedge?

Thanks for any ideas,

Surf

Link to post
BearCreekBum

Surf,

You have version 2 of the power wedge and that does not have a separate Lenco control box but it is built into the main Medallion box. 

Not exactly sure how your PW is controlled with Maliview, but you might try to unplug the MUX control to see if that is causing the constant on condition.

Good luck.
 

 

Link to post

If the MUX switches are working correctly, then you likely have a failure in the main medallion power module under the dash where the fuses are located.

Link to post
  • 1 month later...

Thank you for your responses.  I've been trying to contact the mechanic that did the actuator install but as luck would have it, he no longer works at the shop and no luck trying to contact him. 

Other shops contacted wanted the boat dropped off with basically a blank cheque just to start investigating since they had not encountered this problem.

As indicated, it is most likely the medallion power module or maybe the fuse block itself.

Anyone know of a good source for these items?

 

Link to post
2 hours ago, Surf said:

Thank you for your responses.  I've been trying to contact the mechanic that did the actuator install but as luck would have it, he no longer works at the shop and no luck trying to contact him. 

Other shops contacted wanted the boat dropped off with basically a blank cheque just to start investigating since they had not encountered this problem.

As indicated, it is most likely the medallion power module or maybe the fuse block itself.

Anyone know of a good source for these items?

 

A Malibu dealer or possibly Medallion would be the best source for those parts.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...