Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Starboard ballast fills much slower than port


MustGoFast

Recommended Posts

Curious if anyone has any ideas here...

At some point around the end of my first summer the starboard rear locker started filling much slower than the port.  In fact when I turn on fill all; the front and center fill first, then the port rear, and at that point the PnP bag in starboard is just starting to fill (so floor locker is full and its starting to do the upper or only about 1/3 full).  This means at least 10 extra minutes of just waiting for that one bag to fill.

I've had this checked at the dealer twice now after each season with nothing we can find.  They've checked for line clogs, verified the voltage is correct at the pump, and changed the pump still no change to the performance - any other ideas, its just really annoying..

Link to post
10 hours ago, 02vlxbu said:

You need to replace the impeller in your ballast pump sir 

He said changed the pump. May be some sort of kink or some sort of priming issue

Link to post

Make sure that pump is getting a full 12v when it is turned on.i had a friend boat that had a bad connector on the pump and it was coursing the pump to receive like 7v so wouldn’t pump really good

Link to post
On 9/10/2020 at 3:10 PM, MustGoFast said:

Curious if anyone has any ideas here...

At some point around the end of my first summer the starboard rear locker started filling much slower than the port.  In fact when I turn on fill all; the front and center fill first, then the port rear, and at that point the PnP bag in starboard is just starting to fill (so floor locker is full and its starting to do the upper or only about 1/3 full).  This means at least 10 extra minutes of just waiting for that one bag to fill.

I've had this checked at the dealer twice now after each season with nothing we can find.  They've checked for line clogs, verified the voltage is correct at the pump, and changed the pump still no change to the performance - any other ideas, its just really annoying..

is your lever handle on the pnp fill valve turned cross the valve vs in line with the valve?

also check the bottom vent/over flow in the front of the locker when sac is just starting to fill snd see if you have the tank overflow filling the sack from that end as we know the drain is working so the overflow is probably coming in the drain end 

your sac fills from the top valve with hsndle and the overflow/vent snd overflow/drain

Edited by granddaddy55
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...