Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Medallion troubleshooting 2005 LSV

Recommended Posts

anyone have trouble shooting guide on the 2005 medallion computer and gauges. I have verified the wire from the ecm to be free of high resistence or damage. It did have the orange/black wire at the  the mefi 4b ecm had rubbed into on the engine harness side. That was repaired but still no gauges. They do flutter when ignition is turned on. The fuel gauges works, but the volt/oil/temp does not. The speedo does not work but the digital display does come on. The tach does not work. The medallion number is 7020-20019-01

Link to comment

I had looked into that at bakes, I don't have the medallion II with the 2 water ports for the speedo. My boat has the paddle wheel for the speedo. It shows on their website up to 2004, then the 2005 is different

Link to comment

The LAKE TEMP screen is where the gauge self test mode is located.  If you hold the LCD button down for 3 seconds when lake temp is displayed the system will perform a self test.  The self test will turn on all segments of the display and sweep the gauges from left to middle to right twice.  Then it will return to normal operation.  This will let you know if the MMDC to the gauges are working.

You can also swap the connector from a known working gauge to one that isn't working to help isolate a faulty gauge from a faulty harness plug.

The temp, RPM, pressure, speed, and alarms are sent from the ECM on the CAN though the boat harness that connects to the engine harness and dash harness with a 16 pin rectangular connector with two rows of 8 pins.


Link to comment

Csleaver thanks, i did what you suggested, the volt/temp/oil/fuel did sweep, the speedo Needle did nothing and the tach did nothing. The tach does not have the  5 pin connector though, just wires to ign, ground and signal post. It also has the perfect pass in the tach gauge. I did swap the multi gauge and speedo gauge connector, same result. Multi gauge worked and speedo did not move. The tach needle is froze in 600 rpm if that helps. It does have ground and 12v to the tach. I suppose the speedo and tach gauge is bad? Does the multi gauge sweeping mean the mmdc is good? It would be from the mmdc to the ecm or the ecm itself? Thanks for the help

Edited by Kelley1
Added thanks
Link to comment

The test is only from the MMDC to the gauges and does not include the ECM or other gauge inputs.  If the Speedo didn't work during the test even after swapping the plug it is very likely a bad gauge.  The tach sounds like it is analog with the PPass screen attached to it and is also very likely bad.

Link to comment

thanks again, I need to find a pin out and schematic input and outputs. Hopefully someone will chime in. I believe 2005 was the first year of the can bus era on the malibu.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...