Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

In Boat Speakers Not Working / 2016 23LSV ? Rockford Fosgate


450Ryder

Recommended Posts

Hi All, 

Took the boat out this past weekend and the in boat speakers are not working.  The tower speakers and the sub works, just not the cabin speakers. 

I looked in the storage locker and located the AMP that powers those speakers and the connections are intact and look good. The Blue light indicating power going to the AMP is on.  I tried the EQ on the touch screen and messed with the fade to no success.   Has anyone else had this issue? 

Am I missing something in regards to trouble shooting?  I'd take it in for warranty, but don't want to be without my boat for 2-3 weeks. 

 

Link to comment

What I would check is the RCA wires from the blackbox to the amp.  The blackbox will be in the same observers compartment as the amps.  Check out this thread for troubleshooting the amp, good luck.

Here's also a link to wiring diagram of the RFX5000 (blackbox) I'm pretty sure its the same one you have its the one I had on my 2016 VTX

https://www.rocktheboatmarinestereo.com/specs/RFX5000.pdf

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...